Opened 5 years ago

Closed 4 years ago

#2194 closed defect (fixed)

ffplay: iff ilbm output changes after seeking with the mouse

Reported by: ami_stuff Owned by:
Priority: important Component: avformat
Version: git-master Keywords: iff regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

http://www.datafilehost.com/download-49e8cc93.html

ffplay ilbm24.iff
ffplay version 1.1.git-05340be Copyright (c) 2003-2013 the FFmpeg developers
  built on Jan 22 2013 04:21:12 with gcc 4.5.0 (GCC)
  libavutil      52. 15.100 / 52. 15.100
  libavcodec     54. 90.100 / 54. 90.100
  libavformat    54. 61.102 / 54. 61.102
  libavdevice    54.  3.102 / 54.  3.102
  libavfilter     3. 33.100 /  3. 33.100
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
[iff @ 0x110bdb60] Estimating duration from bitrate, this may be inaccurate
Input #0, iff, from 'ilbm24.iff':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: iff_ilbm (ILBM / 0x4D424C49), 0bgr, 1024x768, SAR 22:22 DAR 4:3, 90k tbr, 90k tbn, 90k tbc
Frame changed from size:0x0 to size:1024x768aq=    0KB vq=    0KB sq=    0B f=0/0   
29223372036854771712.00 A-V:  0.000 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0   
Frame changed from size:1024x768 to size:1024x768  0KB vq=    0KB sq=    0B f=0/0   
29223372036854773760.00 A-V:  0.000 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0   
   1.06 A-V:  0.000 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0   

Attachments (1)

ilbm24.iff (1.9 MB) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by cehoyos

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords iff regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Regression since 7f7f31b.

comment:2 Changed 5 years ago by richardpl

This is single frame, so seeking should not do this. Except seeking with mouse triggers byte seek and than unthinkable happens. This is really not regression because previous code did not cared for seeking of any kind of codec supported in such container.

Last edited 5 years ago by richardpl (previous) (diff)

comment:3 Changed 4 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.