Opened 5 years ago

Closed 5 years ago

#2183 closed defect (fixed)

dsputil_mmx.c "gmc_mmx undeclared" when configuring with --disable-everything

Reported by: jamal Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: dsputil regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

CC      libavcodec/x86/dsputil_mmx.o
/home/jamrial/ffmpeg/libavcodec/x86/dsputil_mmx.c: In function 'dsputil_init_mmx':
/home/jamrial/ffmpeg/libavcodec/x86/dsputil_mmx.c:2053:14: error: 'gmc_mmx' undeclared (first use in this function)
/home/jamrial/ffmpeg/libavcodec/x86/dsputil_mmx.c:2053:14: note: each undeclared identifier is reported only once for each function it appears in

How to reproduce:

./configure --disable-everything

This only happens with an x86_32 target.

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords regression added
  • Status changed from new to open

Regression since f023003, patch on ffmpeg-devel.

comment:2 Changed 5 years ago by cehoyos

The build failure is a regression since a41bf09.

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed, thank you for the report!

Note: See TracTickets for help on using tickets.