Opened 5 years ago

Closed 5 years ago

#2182 closed defect (invalid)

Padding options lack documentation

Reported by: matteosistisette Owned by:
Priority: minor Component: documentation
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

http://ffmpeg.org/ffmpeg.html

ALL is said about padding is:

‘-padtop size’
‘-padbottom size’
‘-padleft size’
‘-padright size’
‘-padcolor hex_color’
All the pad options have been removed. Use -vf pad=width:height:x:y:color instead.

Not a word about the exact meaning of each of the height, width, x and y parameters. Is width the added width or the total width of original video plus padding? How are the x and y offset measured? Are these options applicable to input, output, or both? How do they combine with "-s"? The answers are FAR from obvious and MUST be addressed.

The only way to figure out with such documentation is by testing.

Change History (5)

comment:1 in reply to: ↑ description Changed 5 years ago by saste

Replying to matteosistisette:

http://ffmpeg.org/ffmpeg.html

ALL is said about padding is:

‘-padtop size’
‘-padbottom size’
‘-padleft size’
‘-padright size’
‘-padcolor hex_color’
All the pad options have been removed. Use -vf pad=width:height:x:y:color instead.

Not a word about the exact meaning of each of the height, width, x and y parameters. Is width the added width or the total width of original video plus padding? How are the x and y offset measured? Are these options applicable to input, output, or both? How do they combine with "-s"? The answers are FAR from obvious and MUST be addressed.

The only way to figure out with such documentation is by testing.

Or you could read the -vf option documentation, which in turn points to the filters manual.

comment:2 Changed 5 years ago by matteosistisette

Actually it doesn't. It points to: http://ffmpeg.org/ffmpeg.html#filter_005foption (which is within the same page) where no word is said about padding.

comment:3 follow-up: Changed 5 years ago by matteosistisette

Oh, I see. It "points to" it in the pre-hypertext sense. You're right.

comment:4 Changed 5 years ago by cehoyos

  • Priority changed from important to minor

comment:5 in reply to: ↑ 3 Changed 5 years ago by saste

  • Resolution set to invalid
  • Status changed from new to closed

Replying to matteosistisette:

Oh, I see. It "points to" it in the pre-hypertext sense. You're right.

Hypertext linking would be possible in principle but would require a major rework of our doc building chain (e.g.: switching to pandoc and add indexing support).

Thus I'm closing the ticket since the latter issue is unrelated (padding is indeed documented in the filters manual).

Note: See TracTickets for help on using tickets.