Opened 5 years ago

Closed 5 years ago

#2167 closed defect (fixed)

Srt demuxer problem

Reported by: zoominla Owned by:
Priority: important Component: avformat
Version: git-master Keywords: srt regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by cehoyos)

Reproduce command line:
ffmpeg.exe -i test.srt -y test.ass

Full output of ffmpeg:

ffmpeg version 1.1.1 Copyright (c) 2000-2013 the FFmpeg developers
  built on Jan 22 2013 17:45:30 with gcc 4.6.2 (GCC)
  configuration: --enable-gpl --enable-nonfree --enable-libtheora --enable-versi
on3 --enable-shared --enable-postproc --enable-pthreads --enable-memalign-hack -
-enable-libopencore-amrnb --enable-libopencore-amrwb --enable-runtime-cpudetect
--enable-libass --disable-doc --disable-static --disable-devices --disable-avdev
ice --disable-ffserver --disable-w32threads --extra-cflags=-U__STRICT_ANSI__ --e
xtra-libs='-Wl,--enable-auto-import' --extra-libs=-liconv --extra-libs=-lenca --
extra-libs=-lexpat --extra-libs=-lfreetype --extra-libs=-lfribidi --enable-libmp
3lame --enable-libaacplus --extra-cflags=-I/usr/local/x264/include --extra-ldfla
gs=-L/usr/local/x264/lib --prefix=/usr/local/ffmpeg
  libavutil      52. 15.100 / 52. 15.100
  libavcodec     54. 90.100 / 54. 90.100
  libavformat    54. 61.102 / 54. 61.102
  libavfilter     3. 33.100 /  3. 33.100
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
test.srt: Not enough space

Comment: Last version (v1.0) doesn't have the problem, if i replace the file libavformat/srtdec.c with that from v1.0, the problem will be fixed.

Attachments (1)

test.srt (202.3 KB) - added by zoominla 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by zoominla

comment:1 Changed 5 years ago by cehoyos

  • Description modified (diff)
  • Keywords srt regression added; Srtdec removed
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from 1.1.1 to git-master

Regression since 3af3a30.

comment:2 Changed 5 years ago by cehoyos

  • Summary changed from Srt decoder problem to Srt demuxer problem

comment:3 Changed 5 years ago by ubitux

  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed in f2b6aabd. Sorry about the regression.

Note: See TracTickets for help on using tickets.