Opened 4 years ago

Closed 4 years ago

#2115 closed defect (fixed)

Hinting using ffmpeg

Reported by: vkroutik Owned by:
Priority: minor Component: documentation
Version: git-master Keywords: mov
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Please do not kill me for asking for a feature. It seems that everyone is using mp4box to hint the file for progressive playback after ffmpeg.

It is a simple feature request, why ffmpeg does not have hinting capabilities to avoid using yet another tool?

Thank you.

Change History (8)

comment:1 Changed 4 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords mov added
  • Priority changed from normal to wish

Did you test the -rtphint options?
Is it what you are searching for? If not, what is the difference?

Version 0, edited 4 years ago by cehoyos (next)

comment:2 follow-up: Changed 4 years ago by vkroutik

Thank you for the "hint", I did not know about the flag. How do I check if hint tracks are added? Thank you.

comment:3 in reply to: ↑ 2 Changed 4 years ago by cehoyos

Replying to vkroutik:

How do I check if hint tracks are added?

I have absolutely no idea, but since you requested the feature I would have expected you to know?

comment:4 Changed 4 years ago by vkroutik

Ah, here is a tool which shows that file has hint tracks:
http://sourceforge.net/projects/mp4ui

comment:5 Changed 4 years ago by cehoyos

Do I understand correctly that there is no problem and I can close the ticket?

Last edited 4 years ago by cehoyos (previous) (diff)

comment:6 Changed 4 years ago by vkroutik

yes, please close it, your hinting as good as mp4box, I wish it was documented somewhere.

comment:7 Changed 4 years ago by cehoyos

  • Component changed from undetermined to documentation
  • Priority changed from wish to minor
  • Status changed from new to open
  • Type changed from enhancement to defect
  • Version changed from unspecified to git-master

Searching for "hint" in "ffmpeg -h full" only shows this option: Where else did you search?

comment:8 Changed 4 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

I added -movflags rtphint to the mov muxer documentation.

Note: See TracTickets for help on using tickets.