Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2109 closed defect (duplicate)

rename file name time.h

Reported by: dademvi Owned by:
Priority: normal Component: avutil
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

1. create code using time_t or struct tm and include time.h
2. build with cflag -I$MY_INCLUDE/libavutil

It complain with message "error: field 'time' has incomplete type" etc...
since time.h in libavutil/ is hide time.h in stdlibc, I think you should change that file name.
Anyone who use ffmpeg don't want to modify their build system at every Makefile and project.

BR,
Choi

Change History (3)

comment:1 Changed 6 years ago by Cigaes

If your build system decides to add -Ipath/to/libavutil by itself, it is utterly broken. Please report the bug to whoever produced it.
Renaming a publicly installed header is a major API break, do not expect it just to accomodate such a trivial issue.

comment:2 Changed 6 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 1.0.1 to git-master

See #1783 and please fix your build system.

comment:3 Changed 6 years ago by cehoyos

  • Analyzed by developer unset
  • Reproduced by developer unset
Note: See TracTickets for help on using tickets.