Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2101 closed defect (worksforme)

-start_number is missing documentation

Reported by: norman_hendrich Owned by: llogan
Priority: minor Component: documentation
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Hi guys,

I just wasted a couple of hours of my life reading broken
ffmpeg documentation. A friend sent me a nice script
to create a time-lapse video from existing JPEGs using
ffmpeg, but it didn't work.

Documentation was a complete disaster, and error-messages
misleading. Debugging with strace finally showed what the
stupid thing was doing. Adding one line of documentation
will fix this.

Summary of the bug:
How to reproduce:

What my friend sent me:

ffmpeg -f image2 -r 60 -i mod_image%d.jpg -r 60 -vcodec libx264 video.mp4

What I have:
Ubuntu 12.04 LTS with most recent upstream ffmpeg (0.8 something).

trial-005-camera0.jpg
trial-006-camera0.jpg
trial-007-camera0.jpg
...

this didn't work out-of-the-box. You may already suspect, why.

BUG 1:
What the online docs document: -pattern_type glob ...
This does NOT work on Ubuntu 12.04LTS. The option may have been added
later, but it is not on the actual install. Online docs might mention
that this option has only been added recently (if it is indeed working
somewhere. I have my doubts this option will handle the start-index
bug mentioned below).

BUG 2:
This particular ffmpeg version tells me that it is outdated,
and I should run avconv instead. No need to tell you, avconv
has the same options documented, but doesn't work on 12.04 either.

BUG 3:
I finally understood that foo-%d-bar.jpg was not supported.
Renaming all my files to the foo-%d.jpg pattern was easy.

Running the above script (with "-i mod_image%d.jpg") still tells
me "No such file". Strace shows it checks 000 .. 004 and then gives
up. This is highly non-transparent to the unsuspecting user.

Please DOCUMENT that your s/f...../fine program REQUIRES the image numbering
to start with 0..4, or it will give up. Needless to say, my images
started with 005. That would add only one line in the online docs.

Another idea would be to have a "start index" option.

Probably affects all versions.

Change History (13)

comment:1 Changed 4 years ago by llogan

  • Component changed from undetermined to documentation
  • Keywords Documentation incomplete removed
  • Resolution set to invalid
  • Status changed from new to closed

Ubuntu does not provide ffmpeg from the FFmpeg project, but a fake version from a third-party fork which we can not support here. Ubuntu's continued use of the name "ffmpeg" has been very misleading to users as you have now experienced. See http://stackoverflow.com/a/9477756/1109017 for more info.

Online documentation is regenerated nightly and corresponds to the latest FFmpeg code which you are not using. You must consult your locally installed documentation, request support from Ubuntu or from the upstream fork, or use real ffmpeg from the FFmpeg project (see https://ffmpeg.org/trac/ffmpeg/wiki/UbuntuCompilationGuide if you need compiling help).

A "start index" option already exists and is called "-start_number".

comment:2 Changed 4 years ago by norman_hendrich

  • Resolution invalid deleted
  • Status changed from closed to reopened

OK, sorry to hear that Ubuntu uses a non-supported version.

Would it be a lot of work to mention the "-start_number" option
in the online docs of the "real" ffmpeg version near the
-pattern_type glob and the "-i foo%d.jpg" thingy?

I am certain that I was reading the "official" ffmpeg docs today,
as found by googe, and I guess that mentioning the -start_number
is both easy and might help a couple of users.

comment:3 Changed 4 years ago by llogan

  • Analyzed by developer set
  • Owner set to llogan
  • Priority changed from normal to minor
  • Status changed from reopened to open
  • Summary changed from Please document -i foo%d.jpg correctly to -start_number is missing documentation
  • Version changed from unspecified to git-master

It wouldn't be much work--especially since I made a patch for it 6 months ago but never pushed it. I'll re-visit the patch.

comment:4 Changed 4 years ago by norman_hendrich

OK, definitely "minor".

But if you manage to update the docs with "-start_number" at
the right places, please do. I am happy to download & build
& test a patch, once ready.

Thanks,

Norman

comment:5 Changed 4 years ago by cehoyos

  • Resolution set to worksforme
  • Status changed from open to closed

http://ffmpeg.org/ffmpeg-formats.html#image2-2
While I am sorry to read that the FFmpeg documentation did not help you, reading your original post makes me think that this is not really the fault of the FFmpeg developers but the fault of the Ubuntu packager who has chosen to provide you with an intentionally broken version of FFmpeg that is known to contain several hundred user-reported bugs that are fixed in current FFmpeg, some of them security-relevant.

comment:6 follow-up: Changed 4 years ago by norman_hendrich

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Sorry guys,

Ubuntu or not, the "-start_number" option is NOT in your OFFICIAL online
docs, at least not where I was looking for it. Unless Google directed me
to a faked clone of the ffmpeg webpage? Otherwise, please tell me WHERE
I overlooked this on your official webpage.

I reopen this bug once more, and hope that the issue is documented.
Just closing a bug report TWICE in thirty minutes is not helping to get
users to submit useful bug reports in the first place.

I am sorry to hear that Ubuntu is providing a broken ffmpeg in their
long-term-support version, but that doesn't mean your documentation
is clean.

Cheers, Norman

comment:7 Changed 4 years ago by ubitux

llogan is going to add the documentation for that option soon. While we are it, do you want some other clarifications on this format?

Last edited 4 years ago by ubitux (previous) (diff)

comment:8 Changed 4 years ago by llogan

I should have been more clear, but I was referring to the FAQ at http://ffmpeg.org/faq.html which I assumed you were looking at, and Carl is referring to the official documentation. See the link Carl provided. I still (eventually) plan on adding the example to the FAQ.

comment:9 Changed 4 years ago by saste

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from reopened to closed

Hi,

documentation for -start_number was properly added with the commit:

commit 9bece760097bf1de120e47aa504c9a9ca54d4490
Author: Stefano Sabatini <stefasab@gmail.com>
Date:   Sun Aug 5 10:04:02 2012 +0200

    lavf/img2dec: add start_number_range option

and is documented in your local ffmpeg-formats(1) manual (assuming you're using a proper version of ffmpeg). I also pushed the six-months-old patch by Lou:

commit 091ce6bcb21e860cfe726e83f16e99e280c90e1a
Author: Lou Logan <lou@lrcd.com>
Date:   Mon Jun 25 14:37:01 2012 -0800

    doc/faq: add -start_number example
    
    Also add example showing cat piping images to ffmpeg.
    
    Signed-off-by: Stefano Sabatini <stefasab@gmail.com>

Also please make sure that you read the first line of http://ffmpeg.org/documentation.html.

Version 0, edited 4 years ago by saste (next)

comment:10 in reply to: ↑ 6 Changed 4 years ago by cehoyos

  • Resolution changed from fixed to worksforme

Replying to norman_hendrich:

Ubuntu or not, the "-start_number" option is NOT in your OFFICIAL online
docs, at least not where I was looking for it.

Did you read the link I posted above?
The documentation was there for several months (and please note that it is "near the
-pattern_type glob and the "-i foo%d.jpg" thingy" as you requested).

Unless Google directed me to a faked clone of the ffmpeg webpage?

Where did Google direct you?

Otherwise, please tell me WHERE I overlooked this on your official webpage.

Didn't I do this?

comment:11 follow-up: Changed 4 years ago by norman_hendrich

Oops, I overlooked the FAQ link.

Where did Google direct you

http://ffmpeg.org/ffmpeg.html

There is no "-start_number" there, nor in the ffmpeg man pages
on my system.

I then tried to Google for -pattern_type which didn't work in my
(as I now know, broken Ubuntu ) version of ffmpeg. Unfortunately
this didn't point me to the FAQ either.

comment:12 Changed 4 years ago by Cigaes

-start_number is not a feature of ffmpeg, it is a feature of the part that allows to read individual images. Therefore:
http://ffmpeg.org/documentation.htmlhttp://ffmpeg.org/ffmpeg-formats.html
and there you are.

comment:13 in reply to: ↑ 11 Changed 4 years ago by cehoyos

Replying to norman_hendrich:

Oops, I overlooked the FAQ link.

I did not post the FAQ link but a link to the documentation of the image2 demuxer which includes the -start_number option.

Note: See TracTickets for help on using tickets.