Opened 6 years ago

Closed 6 years ago

#2079 closed defect (fixed)

Configure script processes nonexistent in/outdevs, de/muxers and de/encoders named "x"

Reported by: jamal Owned by:
Priority: important Component: build system
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Commit c73c87b made some cosmetic changes that broke the output of a sed regexp from the configure script, generating nonexistent components called "x".

Example of the configure script output on a default win32 build:

Enabled decoders:
aac			c93			indeo4
aac_latm		cavs			indeo5
[...]
ptx			tiff			x
qcelp			tmv			xan_dpcm
[...]

Enabled encoders:
a64multi		jpegls			png
a64multi5		ljpeg			ppm
[...]
flashsv			pcm_u16le		x
flashsv2		pcm_u24be		xbm
[...]

Enabled demuxers:
aac			iff			pcm_u32le
ac3			ilbc			pcm_u8
[...]
gxf			pcm_s32be		x
h261			pcm_s32le		xa
[...]

Enabled muxers:
a64			image2pipe		pcm_s16be
ac3			ipod			pcm_s16le
[...]
ico			pcm_f64le		x
ilbc			pcm_mulaw		yuv4mpegpipe
image2

Enabled indevs:
lavfi			vfwcap			x

Enabled outdevs:
x

You can see this all around FATE as well.

The problem is that the cosmetic changes made REGISTER_ENCDEC, REGISTER_MUXDEMUX and REGISTER_INOUTDEV be defined in more than one line.

Before

#define REGISTER_INOUTDEV(X,x)  REGISTER_OUTDEV(X,x); REGISTER_INDEV(X,x)

After

#define REGISTER_INOUTDEV(X, x)                                         \
    REGISTER_OUTDEV(X, x);                                              \
    REGISTER_INDEV(X, x)

Since the calls are in their own separate lines, the sed regexp processes them as components.

Easiest solution would be to put them again on a single line.

Change History (3)

comment:1 Changed 6 years ago by cehoyos

  • Priority changed from normal to important

Looks important to me.

comment:2 Changed 6 years ago by cehoyos

  • Keywords regression added
  • Reproduced by developer set
  • Status changed from new to open

comment:3 Changed 6 years ago by ubitux

  • Resolution set to fixed
  • Status changed from open to closed

Haha!

Should be fixed in 613001d7, thanks for the report :)

Note: See TracTickets for help on using tickets.