Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2030 closed defect (invalid)

x264_encoder_open_129

Reported by: cybernet2u Owned by:
Priority: normal Component: build system
Version: git-master Keywords: libx264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

$ ./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid

$ make
ffmpeg version
latest from git
http://git.videolan.org/?p=ffmpeg.git;a=commit;h=3c5c6b9d61361eae3eb989ad8aeca80f0fc05a63

built on Ubuntu 12.04

when i'm trying to "make"
i get
libavcodec/libx264.c:533: error: undefined reference to 'x264_encoder_open_129'
collect2: ld returned 1 exit status
make: * [ffmpeg_g] Error 1

Change History (6)

comment:1 Changed 4 years ago by cybernet2u

comment:2 Changed 4 years ago by cehoyos

  • Component changed from FFmpeg to build system
  • Priority changed from critical to normal

Please confirm that you tried "make distclean && ./configure --enable-gpl --enable-x264 && make" and that it failed with above error. Then please run "make V=1" and post the complete, uncut output of "make V=1" (please do not post the output of the earlier run).

Version 0, edited 4 years ago by cehoyos (next)

comment:3 Changed 4 years ago by cybernet2u

i started fresh

root@node9:~/t# git clone git://source.ffmpeg.org/ffmpeg.git
Cloning into 'ffmpeg'...
remote: Counting objects: 270373, done.
remote: Compressing objects: 100% (58965/58965), done.
remote: Total 270373 (delta 213885), reused 267224 (delta 210985)
Receiving objects: 100% (270373/270373), 67.39 MiB | 1.25 MiB/s, done.
Resolving deltas: 100% (213885/213885), done.
root@node9:~/t# cd ffmpeg/
root@node9:~/t/ffmpeg# make distclean
Makefile:2: config.mak: No such file or directory
Makefile:49: /common.mak: No such file or directory
Makefile:92: /libavutil/Makefile: No such file or directory
Makefile:92: /library.mak: No such file or directory
Makefile:178: /doc/Makefile: No such file or directory
Makefile:179: /tests/Makefile: No such file or directory
make: *** No rule to make target `/tests/Makefile'.  Stop.

root@node9:~/t/ffmpeg# ./configure --enable-gpl
--enable-x264

........................

done

root@node9:~/t/ffmpeg# make
libavcodec/libx264.c:533: error: undefined reference to 'x264_encoder_open_129'
collect2: ld returned 1 exit status
make: *** [ffmpeg_g] Error 1

root@node9:~/t/ffmpeg# make V=1
gcc -Llibavcodec -Llibavdevice -Llibavfilter -Llibavformat -Llibavresample -Llibavutil -Llibpostproc -Llibswscale -Llibswresample -Wl,--as-needed -Wl,--warn-common -Wl,-rpath-link=libpostproc:libswresample:libswscale:libavfilter:libavdevice:libavformat:libavcodec:libavutil:libavresample  -o ffmpeg_g ffmpeg_opt.o ffmpeg_filter.o ffmpeg.o cmdutils.o  -lavdevice -lavfilter -lavformat -lavcodec -lpostproc -lswresample -lswscale -lavutil -ldl -lasound -lSDL -lx264 -lm -pthread -lz -lrt  
libavcodec/libx264.c:533: error: undefined reference to 'x264_encoder_open_129'
collect2: ld returned 1 exit status
make: *** [ffmpeg_g] Error 1

root@node9:~/t/ffmpeg# 

Last edited 4 years ago by cybernet2u (previous) (diff)

comment:4 Changed 4 years ago by cehoyos

Either your x264 include file does not match your library version or you have two different x264 versions installed. Try to uninstall the developer package(s) of libx264.

comment:5 Changed 4 years ago by cehoyos

  • Keywords libx264 added
  • Resolution set to invalid
  • Status changed from new to closed

I don't think there is anything about this ticket that can be fixed in FFmpeg.

comment:6 Changed 4 years ago by hackeron

I had the same issue, running rm /usr/local/lib/libx264.so* fixed it :)

Note: See TracTickets for help on using tickets.