Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#1975 closed defect (needs_more_info)

yadif placement after -i results in timing errors

Reported by: dpury Owned by:
Priority: normal Component: avfilter
Version: unspecified Keywords: yadif dts
Cc: lists.davep@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When using yadif after the input file, pts errors are encountered. On long files this results in a/v sync issues. If I move the yadif filter to before the input file, the errors are not present. Output format doesn't seem to matter; I've seen it when making MPEG-2 PS and TS files, as well as MP4 files. As a workaround, I've been using yadif before the input, and another -filter:v after the input to do scale and setdar.

Report files attached.

This command
ffmpeg -report -i C:\ffmpeg\bin\bip_3s.mxf -filter:v yadif=0 C:\ffmpeg\bin\bip_3s.mp4

produces errors like this:
PTS 14, next:440000 invalid dropping st:0
PTS 17, next:560000 invalid dropping st:0
PTS 20, next:680000 invalid dropping st:0
PTS 23, next:800000 invalid dropping st:0

While this command
ffmpeg -report -filter:v yadif=0 -i C:\ffmpeg\bin\bip_3s.mxf -y C:\ffmpeg\bin\bip_3s.mp4

produces no errors.

Thank you,

dpury

Attachments (5)

ffmpeg-20121128-121923-yadif-after-input.log (16.3 KB) - added by dpury 5 years ago.
this log shows the error when using yadif after the input
ffmpeg-20121128-122017-yadif-before-input.log (15.3 KB) - added by dpury 5 years ago.
this log shows no errors when using yadif before the input
bip_3s.mxf (1.7 MB) - added by dpury 5 years ago.
This is the mxf file I used to make the reports.
ffmpeg-20121128-163042-yadif.log (58.1 KB) - added by dpury 5 years ago.
Here's the log of an interlaced HDV file source being converted to mp4
ffmpeg-20121128-163119-no-yadif.log (23.8 KB) - added by dpury 5 years ago.
Here's the same HDV file converted to mp4 without yadif.

Download all attachments as: .zip

Change History (22)

Changed 5 years ago by dpury

this log shows the error when using yadif after the input

Changed 5 years ago by dpury

this log shows no errors when using yadif before the input

comment:1 in reply to: ↑ description Changed 5 years ago by cehoyos

  • Keywords pts invalid dropping removed

Replying to dpury:

As a workaround, I've been using yadif before the input

This disables the filter (filter only have an affect if specified before the output file and after the input file), so I don't think it can count as a workaround.

Do I understand you correctly that if you yadif (if you place the filter between the input and the output file) the output file plays out-of-sync?
Or are you only reporting that ffmpeg is overly verbose (outputting messages) if you use yadif?

comment:2 Changed 5 years ago by cehoyos

In any case, since I cannot reproduce your problem, please provide a sample of an input file that allows to reproduce the problem.

Changed 5 years ago by dpury

This is the mxf file I used to make the reports.

Changed 5 years ago by dpury

Here's the log of an interlaced HDV file source being converted to mp4

Changed 5 years ago by dpury

Here's the same HDV file converted to mp4 without yadif.

comment:3 Changed 5 years ago by dpury

Thanks for looking into it, Carl. I'll dig around for another source file that I'm allowed to share and is a reasonable size.

comment:4 Changed 5 years ago by dpury

Yes, longer encodes such as full-length movies drift out of sync. I'm not worried about the verbosity.

comment:5 Changed 5 years ago by cehoyos

I tested with the sample you uploaded - bip_3s.mxf - and I can neither reproduce any suspicious messages on the console nor any A/V-desync.

Please reopen if you can provide a sample that allows to reproduce your problem.

comment:6 Changed 5 years ago by cehoyos

  • Resolution set to worksforme
  • Status changed from new to closed

comment:7 Changed 5 years ago by dpury

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:8 follow-up: Changed 5 years ago by dpury

Please try this file. If you still can't reproduce the errors, what's the next step?

http://www.filehosting.org/file/details/398267/motion_525c_RGB235.avi

comment:9 in reply to: ↑ 8 ; follow-up: Changed 5 years ago by cehoyos

Replying to dpury:

http://www.filehosting.org/file/details/398267/motion_525c_RGB235.avi

A hosting site that requires registration is absolutely unacceptable, sorry.

comment:10 in reply to: ↑ 9 Changed 5 years ago by dpury

Replying to cehoyos:

Replying to dpury:

http://www.filehosting.org/file/details/398267/motion_525c_RGB235.avi

A hosting site that requires registration is absolutely unacceptable, sorry.

Sorry about that. I'll upload the file to the hosting company of your choice. Thank you.

comment:11 Changed 5 years ago by rogerdpack

http://ffmpeg.org/bugreports.html describes the ftp server...

comment:12 Changed 5 years ago by cehoyos

You can either upload your sample to our incoming directory (there is no enforced size limit) or upload it to any hosting site that does not require registration.

comment:13 Changed 5 years ago by dpury

File "motion_525c_RGB235.avi" uploaded to /incoming. Thanks!

comment:14 Changed 5 years ago by cehoyos

You originally wrote:

On long files this results in a/v sync issues.

The file you uploaded is video-only, how is it supposed to show A/V sync issues?

comment:15 follow-up: Changed 5 years ago by dpury

I uploaded it because the invalid dropping messages were present if I used yadif.

I have done a little more research, and the issue is not present in the latest 32-bit Zeranoe build. The above reports were made with the latest Zeranoe 64-bit build. I'll take the issue to the Zeranoe forum, and I apologize for wasting your time.

comment:16 in reply to: ↑ 15 Changed 5 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from reopened to closed

Replying to dpury:

I uploaded it because the invalid dropping messages were present if I used yadif.

Above you wrote:

Yes, longer encodes such as full-length movies drift out of sync. I'm not worried about the verbosity.

This may indicate an important bug, so if you want to help, please reopen and provide a sample.

comment:17 Changed 4 years ago by rogerdpack

if this is still a problem with latest builds could you report back here please?

Note: See TracTickets for help on using tickets.