Opened 5 years ago

Closed 4 years ago

#1896 closed defect (wontfix)

configure --enable-bzlib doesn't cause configure to fail if there's no bzlib

Reported by: rogerdpack Owned by:
Priority: normal Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

see the title,
$ ./configure --enable-bzlib

lists this:

...
bzlib enabled no
...

then happily returns true.
Just making a note of it here.
Thanks!

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to build system
  • Version changed from unspecified to git-master

I believe this is expected behaviour because bzlib is a system library but I may miss something.

comment:2 Changed 4 years ago by cehoyos

  • Resolution set to wontfix
  • Status changed from new to closed

configure's help prints:

--disable-bzlib          disable bzlib [autodetect]

explaining that --enable-bzlib has no meaning (it is the default behaviour if bzlib is available).

Note: See TracTickets for help on using tickets.