Opened 6 years ago

Closed 6 years ago

#1886 closed defect (needs_more_info)

avformat_write_header crashes on writing Live Smooth Streaming video

Reported by: Morion Owned by:
Priority: important Component: avformat
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm working on Windows application that uses ffmpeg API to encode and send Live Smooth Streaming video to IIS. I have two machines, on one of them the application works fine but on the other it produces a crash at the avformat_write_header function. I've checked everything and the calls to ffmpeg functions are the same on both machines so only guess I have is that there is a bug in ffmpeg.

The attached file is gdb output. Also I can provide the code that calls ffmpeg function, please let me know if it could help.

Attachments (1)

gdb.txt (14.1 KB) - added by Morion 6 years ago.
gdb output

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Morion

gdb output

comment:1 Changed 6 years ago by cehoyos

How do you call av_dict_free() ?

comment:2 Changed 6 years ago by Morion

I don't call it. I think it is called somewhere in avformat_write_header internally.

comment:3 Changed 6 years ago by cehoyos

Then please remove the stripping from your libraries (run configure with --disable-stripping) to get a useful backtrace.

comment:4 Changed 6 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen if you can add the missing information.

Note: See TracTickets for help on using tickets.