Opened 4 years ago

Closed 4 years ago

#1856 closed enhancement (fixed)

Files ffmpeg cannot convert

Reported by: johann Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: g7231
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


I run an online audio converter that uses ffmpeg, among other tools, to convert audio files.

I have collected a number of files that ffmpeg couldn't convert and I hope you can use them to improve ffmpeg.

I tried to use

% ffmpeg -y -i file.ext -acodec pcm_s16le -ac 2 fnuh.wav

to convert these files.

The ffmpeg version in use is

$ ffmpeg
ffmpeg version 0.10.5-6:0.10.5-0ubuntu0jon1 Copyright (c) 2000-2012 the FFmpeg developers
  built on Oct  1 2012 01:56:55 with gcc 4.6.3
  configuration: --arch=amd64 --enable-pthreads --enable-runtime-cpudetect --extra-version='6:0.10.5-0ubuntu0jon1' --libdir=/usr/lib/x86_64-linux-gnu --disable-stripping --prefix=/usr --enable-bzlib --enable-libdc1394 --enable-libfreetype --enable-frei0r --enable-gnutls --enable-libgsm --enable-libmp3lame --enable-librtmp --enable-libopencv --enable-libopenjpeg --enable-libpulse --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-vaapi --enable-vdpau --enable-libvorbis --enable-libvpx --enable-zlib --enable-gpl --enable-postproc --enable-libcdio --enable-x11grab --enable-libx264 --shlibdir=/usr/lib/x86_64-linux-gnu --enable-shared --disable-static
  libavutil      51. 35.100 / 51. 35.100
  libavcodec     53. 61.100 / 53. 61.100
  libavformat    53. 32.100 / 53. 32.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 61.100 /  2. 61.100
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  6.100 /  0.  6.100
  libpostproc    52.  0.100 / 52.  0.100

Download the files at

Change History (5)

comment:1 Changed 4 years ago by richardpl

  • Priority changed from normal to wish
  • Status changed from new to open
  • Version changed from 0.10.5 to git-master

All 3ga files are invalid - they are missing moov atom. Is there program which can actually decode them?

For one file we have already bug report (non 4-bit ADPCM IMA wav)
And second file is wav with audio tag 0xA100.

comment:2 Changed 4 years ago by johann


thanks for looking into the files.

As for the 3ga files -- do you have any ideas where they could come from? Users upload anything and everything and maybe there's some half-broken cellphone out there that records these?

BTW: file says ISO Media, MPEG v4 system, 3GPP to all the 3ga files.

The wav file with the 0xa100 is using Comverse Infosys Ltd. G723 1, according to this.

Is there a list of TwoCC codecs ffmpeg supports?



comment:4 Changed 4 years ago by johann

Thanks, do you plan to merge this change in the 0.10 branch so it would be available on Ubuntu 12.04?

Also, I was trying to play the 3ga files on my Android tablet but it wouldn't play it.

comment:5 Changed 4 years ago by cehoyos

  • Keywords g7231 added
  • Resolution set to fixed
  • Status changed from open to closed

The problem with adpcm_ima_wav is a duplicate of ticket #1856.

Enhancements are usually not backported, could you send a patch (or setup a git clone) if you need it?

Version 0, edited 4 years ago by cehoyos (next)
Note: See TracTickets for help on using tickets.