Opened 4 years ago

Closed 4 years ago

#1821 closed defect (fixed)

Error processing WAV audio file

Reported by: paulbu Owned by:
Priority: important Component: avformat
Version: git-master Keywords: regression wav
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
WAV files that have worked fine for years as input to ffmpeg are now failing with latest version with following error:
% [wav @ 0003cee0] too big INFO subchunk
% input.wav: Invalid data found when processing input

This is with ffmpeg version N-45279-g1a104bf
Worked fine up to ffmpeg version N-35057-g2c44aed which is the last version I was using before upgrading.

How to reproduce:
% ffmpeg -i input.wav -ab 96k out.mp3

If you need a small sample WAV file let me know. (WAV file produced by Ashampoo Burning Studio as rip from audio CD)

Attachments (2)

input.wav.7z (1.3 MB) - added by paulbu 4 years ago.
7zip of short (30sec) wav file from Ashampoo Burning Studio
test.wav (30.5 KB) - added by nostah 4 years ago.
Wave file with ADPCM data that fails the same way.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 4 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important

Please provide complete, uncut console output of your failing command line together with the failing command line and please provide a sample.

Changed 4 years ago by paulbu

7zip of short (30sec) wav file from Ashampoo Burning Studio

comment:2 Changed 4 years ago by paulbu

Full console dump from ffmpeg with attached wav file as input:
$ /c/dev/audio/ffmpeg-20121010-git-1a104bf-win32-shared/bin/ffmpeg -i input.wav

-ab 96k output.mp3

ffmpeg version N-45279-g1a104bf Copyright (c) 2000-2012 the FFmpeg developers

built on Oct 10 2012 19:21:13 with gcc 4.7.2 (GCC)
configuration: --disable-static --enable-shared --enable-gpl --enable-version3

--disable-pthreads --enable-runtime-cpudetect --enable-avisynth --enable-bzlib

--enable-frei0r --enable-libass --enable-libcelt --enable-libopencore-amrnb --en
able-libopencore-amrwb --enable-libfreetype --enable-libgsm --enable-libmp3lame
--enable-libnut --enable-libopenjpeg --enable-librtmp --enable-libschroedinger -
-enable-libspeex --enable-libtheora --enable-libutvideo --enable-libvo-aacenc --
enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enab
le-libxavs --enable-libxvid --enable-zlib

libavutil 51. 74.100 / 51. 74.100
libavcodec 54. 65.100 / 54. 65.100
libavformat 54. 31.100 / 54. 31.100
libavdevice 54. 3.100 / 54. 3.100
libavfilter 3. 19.102 / 3. 19.102
libswscale 2. 1.101 / 2. 1.101
libswresample 0. 16.100 / 0. 16.100
libpostproc 52. 1.100 / 52. 1.100

[wav @ 00032a20] too big INFO subchunk
input.wav: Invalid data found when processing input

Version 0, edited 4 years ago by paulbu (next)

comment:3 follow-up: Changed 4 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords wav added
  • Reproduced by developer set
  • Status changed from new to open

(The sample can be tested with mplayer -softvol -softvol-max 700 -volume 100)

Regression since 12bc205 / 1e19927

comment:4 in reply to: ↑ 3 ; follow-up: Changed 4 years ago by richardpl

Replying to cehoyos:

(The sample can be tested with mplayer -softvol -softvol-max 700 -volume 100)

Regression since 12bc205 / 1e19927

Not really, it was introduced recently.

problems:
1st: creator of this files puts INFO chunk id at end (instead of start of file).
2nd: size of INFO chunks ids are not word aligned - and any other info on web states it should be word aligned, like how it is done in avi.

comment:5 in reply to: ↑ 4 Changed 4 years ago by cehoyos

Replying to richardpl:

Replying to cehoyos:

Regression since 12bc205 / 1e19927

Not really, it was introduced recently.

Could you elaborate?

comment:6 Changed 4 years ago by richardpl

Regression was not introduced in such commits you mentioned.
Tag reading in wav was added recently.

Last edited 4 years ago by richardpl (previous) (diff)

comment:7 Changed 4 years ago by cehoyos

$ ffmpeg -i input.wav
ffmpeg version N-35243-gca55606, Copyright (c) 2000-2011 the FFmpeg developers
  built on Oct 18 2012 00:10:13 with gcc 4.7.1 20120723 [gcc-4_7-branch revision 189773]
  configuration:
  libavutil    51. 29. 1 / 51. 29. 1
  libavcodec   53. 38. 1 / 53. 38. 1
  libavformat  53. 22. 0 / 53. 22. 0
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 50. 0 /  2. 50. 0
  libswscale    2.  1. 0 /  2.  1. 0
[wav @ 0x2ae37e0] parser not found for codec pcm_s16le, packets or times may be invalid.
[wav @ 0x2ae37e0] max_analyze_duration 5000000 reached at 5015510
Input #0, wav, from 'input.wav':
  Duration: 00:00:30.42, bitrate: 1411 kb/s
    Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, 2 channels, s16, 1411 kb/s
At least one output file must be specified
$ ffmpeg -i input.wav
ffmpeg version N-35255-g1e19927, Copyright (c) 2000-2011 the FFmpeg developers
  built on Oct 18 2012 00:08:35 with gcc 4.7.1 20120723 [gcc-4_7-branch revision 189773]
  configuration:
  libavutil    51. 29. 1 / 51. 29. 1
  libavcodec   53. 38. 1 / 53. 38. 1
  libavformat  53. 22. 0 / 53. 22. 0
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 50. 0 /  2. 50. 0
  libswscale    2.  1. 0 /  2.  1. 0
[wav @ 0x26fd7e0] too big INFO subchunk
input.wav: Invalid data found when processing input

comment:8 Changed 4 years ago by richardpl

uh, yes I'm blind and ignorant.

comment:9 Changed 4 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Michael.

comment:10 Changed 4 years ago by nostah

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have slightly different wav file (with adpcm inside) and also get this error message. It still works fine with very old 0.6.1 (that was in debian stable) but fails with version built from git.

Changed 4 years ago by nostah

Wave file with ADPCM data that fails the same way.

comment:11 Changed 4 years ago by nostah

The file plays fine in VLC (linux) and QT Player (mac).

comment:12 Changed 4 years ago by michael

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.