Opened 6 years ago

Closed 5 years ago

#180 closed defect (fixed)

ffmpeg and ffserver different builds interraction

Reported by: andrixnet Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

First an end user question : has ffserver behaviour changed by design since ffmpeg-0.5 ?

Since having problems with the latest ffserver, I build 0.7-rc1.

Using :
ffmpeg (on a win32)
FFmpeg version SVN-r25857, Copyright (c) 2000-2010 the FFmpeg developers

built on Dec 1 2010 04:07:58 with gcc 4.4.2

and
ffserver 0.7-rc1 (on linux)
results in :

HTTP error 404 Not Found
http://xxxxxxx:8090/feed1.ffm: Input/output error

and in the logs :

Mon May  9 16:38:37 2011 File '/feed1.ffm' not found
Mon May  9 16:38:37 2011 10.1.1.10 - - [GET] "/feed1.ffm HTTP/1.1" 404 149

I was also unable to use the same ffmpeg and ffserver 0.5 with the error "operation not permitted". (no, not a firewall issue).

Then I tried ffmpeg (on win32)
FFmpeg version SVN-r20428, Copyright (c) 2000-2009 Fabrice Bellard, et al.

built on Nov 1 2009 04:03:50 with gcc 4.2.4

with ffserver 0.5 (linux)
and it worked.


then I did a new test with the latest win32 build :
ffmpeg version git-N-29638-g95f163b, Copyright (c) 2000-2011 the FFmpeg developers

built on May 6 2011 12:50:01 with gcc 4.5.3

with ffserver-0.7-rc1
and got :
[http @ 01E78D60] HTTP error 404 Not Found
http://xxxxxxx:8090/feed1.ffm: Input/output error


I am not sure what aspects are to be considered ?

1) different versions for ffmpeg and ffserver should work, regardless of the build and/or platform
2) if the ffserver api has changed since ffmpeg-0.5 time, ffmpeg should report to the user a version incompatibility error message
3) if 2) is not the case, then it is indeed a bug ffmpeg being unable to talk to ffserver

Change History (5)

comment:1 Changed 6 years ago by michael

If this can be reproduced with git master then please try to find out which version broke it.
(git bisect makes this quite easy)

comment:2 Changed 6 years ago by andrixnet

Current versions interraction :

I can reproduce this with same version ffmpeg as well, @ ffmpeg-0.8.

Using default config from source tree.
Using ffmpeg-0.8, just built.

ffserver -f ffserver.conf

ffmpeg -i file.avi http://localhost:8090/feed1.ffm :

[http @ 0x807a840] HTTP error 404 Not Found
http://gate:8090/feed1.ffm: Input/output error
Tue Jun 28 00:05:10 2011 FFserver started.
Tue Jun 28 00:05:45 2011 File '/feed1.ffm' not found
Tue Jun 28 00:05:45 2011 1.2.3.4 - - [GET] "/feed1.ffm HTTP/1.1" 404 149

Same error using windows build of ffmpeg binary :
ffmpeg version N-31031-gf211d9d, Copyright (c) 2000-2011 the FFmpeg developers

built on Jun 26 2011 22:50:39 with gcc 4.5.3

comment:3 Changed 6 years ago by andrixnet

New and old version interraction :

ffmpeg binary v0.8
ffmpeg -i file.avi http://somehost:8090/feed1.ffm :

http://somehost:8090/feed1.ffm: Operation not permitted

ffserver version 0.5, in the logs :

Tue Jun 28 00:10:30 2011 1.2.3.4 - - [GET] "/feed1.ffm HTTP/1.1" 200 12341

comment:4 Changed 6 years ago by andrixnet

Have yet to identify the change that broke things. (git bisect)

comment:5 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from new to closed

This issue is fixed in git master, future ffserver and ffmpeg versions should cooperate better. About past versions from last year, theres not much that can be done, even just detecting the problem is not trivial

Note: See TracTickets for help on using tickets.