Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1786 closed defect (invalid)

Displaying Green Color video

Reported by: neelima Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

We are currently working on this Android 3D Animation App. We need to do video encoding as well as audio syncup on encoded video. We are using ffmpeg tool for this video encoding.

Sequential Steps taken by us:-
Step 1. We are taking screenshots of the identified images for video encoding exercise.
Step 2. Saving them in SDCard.
Step 3. Then we are calling the avcodec_init method and subsequently avcodec_register_all method.
Step 4. Then we are reading the SDCard images and allocating them to memory in FFmpeg.
Step 5. Then we are calling rgb2yuv method.

Then we are getting output source as green color video. Please help us where we are missing. Whether this issue is in rgb2yuv method.

Many Thanks in Advance.

Attachments (1)

vidapi.c (18.3 KB) - added by neelima 4 years ago.
This file is for video encoding

Download all attachments as: .zip

Change History (7)

comment:1 follow-up: Changed 4 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords FFmpeg Android removed
  • Priority changed from critical to normal
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 0.8.12 to unspecified

comment:2 in reply to: ↑ 1 Changed 4 years ago by neelima

Can we know why is this closed without any comments.

comment:3 Changed 4 years ago by cehoyos

I asked you in ticket #1772 to add some information and to test current git head.
You did not answer, instead you are opening new tickets that do not contain enough information to reproduce your problem.

Changed 4 years ago by neelima

This file is for video encoding

comment:4 follow-up: Changed 4 years ago by neelima

We have attached vidapi.c file. We request you to please review our code in encodeVideo() method. Thanks in advance.

comment:5 in reply to: ↑ 4 Changed 4 years ago by cehoyos

Replying to neelima:

We have attached vidapi.c file. We request you to please review our code in encodeVideo() method.

I fear there is a misunderstanding:
This forum is for bugs in FFmpeg, not for bugs in software using FFmpeg (and not for FFmpeg support).
Please read https://ffmpeg.org/contact.html to find out about support mailing lists.

comment:6 Changed 4 years ago by reimar

Just as a hint in case it helps: a all-green frame means a YUV frame probably had its all-0 initialization value. So sws_scale probably never writes into the destination frame.
But I see no real reason to believe this is a but in FFmpeg, if you do please provide an absolutely minimal test-case that proves it.
I'm afraid we can't help you debugging your code, we don't have enough resources for that.

Version 0, edited 4 years ago by reimar (next)
Note: See TracTickets for help on using tickets.