Opened 5 years ago

Closed 5 years ago

#1763 closed defect (fixed)

Audio encoding assumes a channel layout

Reported by: cehoyos Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Related to ticket #1474, reproducible with the samples from ticket #1608 and currently blocks ticket #98 (where the sample shows a wrong channel layout, this cannot be currently fixed to "unknown").

$ ffmpeg -ac 16 -f s16le -i /dev/zero -t 1 out.wav
ffmpeg version N-44739-g4390f8c Copyright (c) 2000-2012 the FFmpeg developers
  built on Sep 25 2012 09:25:02 with gcc 4.5.3 (GCC)
  configuration: --cc=/usr/local/gcc-4.5.3/bin/gcc --enable-gpl
  libavutil      51. 73.101 / 51. 73.101
  libavcodec     54. 58.100 / 54. 58.100
  libavformat    54. 28.101 / 54. 28.101
  libavdevice    54.  2.101 / 54.  2.101
  libavfilter     3. 17.100 /  3. 17.100
  libswscale      2.  1.101 /  2.  1.101
  libswresample   0. 15.100 /  0. 15.100
  libpostproc    52.  0.100 / 52.  0.100
[s16le @ 0x1505320] Invalid sample rate 0 specified using default of 44100
[s16le @ 0x1505320] Estimating duration from bitrate, this may be inaccurate
Input #0, s16le, from '/dev/zero':
  Duration: N/A, start: 0.000000, bitrate: 11289 kb/s
    Stream #0:0: Audio: pcm_s16le, 44100 Hz, 16 channels, s16, 11289 kb/s
[graph 0 input from stream 0:0 @ 0x1511aa0] Invalid channel layout '0x0'
Error opening filters!

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open

Regression since e387c9d / d3c59d5.

Ticket #1957 is probably a duplicate of this ticket.

comment:2 Changed 5 years ago by cehoyos

Fixed by Nicolas.

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.