Opened 4 years ago

Closed 4 years ago

#1682 closed defect (invalid)

DVD '-target' option affects video filters

Reported by: intracube Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Trying to convert an interlaced video which isn't a valid DVD resolution (such as 1920x1080i) to either 720x576@50i or 720x576@25p DVD video using '-target' stops video filters from working properly.

The -target option looks like it's re-scaling the video *before* the -vf video filter chain. This messes up the field interleaving and stops de-interlacers like yadif from working.

Encoding without using '-target' works as expected.

Examples:
This creates badly de-interlaced video:
ffmpeg -i 1080i.MTS -vf yadif=0,scale=720:576 -r 25 -target pal-dvd -aspect 16:9 output1.mpg
(I can paste console output if necessary - but I could see no errors there)

This creates clean de-interlaced h264 video:
ffmpeg -i 1080i.MTS -vf yadif=0,scale=720:576 -r 25 -c:v libx264 -crf 18 -preset fast -c:a ac3 -ac 2 -b:a 224k -aspect 16:9 output2.mp4

This creates clean de-interlaced mpeg2 video:
ffmpeg -i 1080i.MTS -vf yadif=0,scale=720:576 -r 25 -c:v mpeg2video -b 8000k -c:a ac3 -ac 2 -b:a 224k -aspect 16:9 output3.mpg

  • but this isn't compatible with dvdauthor.

dvdauthor errors:
WARN: Skipping sector, waiting for first VOBU...
WARN: Skipping sector, waiting for first VOBU...
WARN: Skipping sector, waiting for first VOBU...
...
ERR: SCR moves backwards, remultiplex input: 4563416160 < 4563429486

Repeatable:
Always.

Ffmpeg version:
ffmpeg version N-43891-g65b552c Copyright (c) 2000-2012 the FFmpeg developers

built on Aug 25 2012 15:54:15 with gcc 4.6 (SUSE Linux)
configuration: --prefix=/home/compile/ffmpeg --bindir=/home/compile/ffmpeg/bin --datadir=/home/compile/ffmpeg/share/ffmpeg --libdir=/home/compile/ffmpeg/lib --shlibdir=/home/compile/ffmpeg/lib --incdir=/home/compile/ffmpeg/include --mandir=/home/compile/ffmpeg/share.man --enable-avresample --enable-x11grab --enable-libdc1394 --enable-libfaac --enable-libmp3lame --enable-librtmp --enable-libtheora --enable-libtwolame --enable-libv4l2 --enable-libvpx --enable-libx264 --enable-libxvid --enable-gpl --enable-nonfree
libavutil 51. 70.100 / 51. 70.100
libavcodec 54. 54.100 / 54. 54.100
libavformat 54. 25.104 / 54. 25.104
libavdevice 54. 2.100 / 54. 2.100
libavfilter 3. 13.101 / 3. 13.101
libswscale 2. 1.101 / 2. 1.101
libswresample 0. 15.100 / 0. 15.100
libpostproc 52. 0.100 / 52. 0.100

Attachments (1)

output.log (66.8 KB) - added by intracube 4 years ago.
ffmpeg command line output

Download all attachments as: .zip

Change History (6)

comment:1 follow-up: Changed 4 years ago by cehoyos

  • Keywords target preset video filter deinterlace scale removed

Please add complete, uncut console output together with your failing command line.

Changed 4 years ago by intracube

ffmpeg command line output

comment:2 in reply to: ↑ 1 ; follow-up: Changed 4 years ago by intracube

Replying to cehoyos:

Please add complete, uncut console output together with your failing command line.

Full command line output added as attachment.

What was the reason for removing a lot of the ticket keywords?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 4 years ago by cehoyos

Replying to intracube:

Replying to cehoyos:

Please add complete, uncut console output together with your failing command line.

Full command line output added as attachment.

(Any reason for not simply posting it?)

What was the reason for removing a lot of the ticket keywords?

The full-text search works well and I am trying to keep the number of keywords manageable.
I also don't think video and filter are good keywords, and I am assuming the problem is also reproducible without -target when using the corresponding options, deinterlace is too general imo and preset is simply wrong afaict.

comment:4 in reply to: ↑ 3 Changed 4 years ago by intracube

Replying to cehoyos:

(Any reason for not simply posting it?)

As it's over 800 lines long, it would mean a lot of scrolling to get down to these comments.

I've just run this test again, and I can't reproduce the bug. I can only think I was running the older version of ffmpeg (installed through my package manager) rather than the up-to-date locally compiled version.

I thought I double checked that, too...

Sorry, this ticket can be closed.

Last edited 4 years ago by intracube (previous) (diff)

comment:5 Changed 4 years ago by cehoyos

  • Keywords dvd yadif removed
  • Resolution set to invalid
  • Status changed from new to closed

Thank you for testing again!

Note: See TracTickets for help on using tickets.