Opened 7 years ago

Closed 2 years ago

#1673 closed defect (fixed)

MPEG2-TS minimum PID value for data packet

Reported by: Magicking Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mpegts
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The minimum PID value for data packet is 0x0100 where is should be 0x0010 as specified by the ISO13818-1 ยง2.4.3.3

Attachments (1)

0001-Set-min-PID-from-0x0100-to-0x0010-for-data-pkt.patchโ€‹ (1.1 KB) - added by Magicking 7 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by cehoyos

  • Keywords mpegts added; pid removed
  • Status changed from new to open

Consider sending patches to ffmpeg-devel, they generally receive more attention there.

comment:2 Changed 6 years ago by mateo

According to the specification the patch looks good to me.
Can someone confirm this since i'm not expert on the mpegtsenc.c.

Note: the patch must be rebased in order to apply on HEAD.

comment:3 Changed 2 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.