Opened 7 years ago

Closed 7 years ago

#1668 closed defect (invalid)

Cannot transcode FLV-contained speex to anything

Reported by: bbhoss Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: speex
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: Trying to transcode a FLV file with speex audio (no video track) into a wav or mp3. This is generated by Flash Media Server 4.5. It works fine using ffmpeg version N-42616-g204c4e9 with gcc 4.4.3 on Ubuntu 10.04 LTS. I am trying to transcode on my dev machine which is OS X Mountain Lion 10.8, using HEAD ffmpeg.
How to reproduce:

➜  ~  ffmpeg -i C773A907-F99C-7AFE-F457-C49B1CC07679.flv rog.wav
ffmpeg version 0.11.1.git Copyright (c) 2000-2012 the FFmpeg developers
  built on Aug 20 2012 14:49:48 with Apple clang version 4.0 (tags/Apple/clang-421.0.57) (based on LLVM 3.1svn)
  configuration: --prefix=/usr/local/Cellar/ffmpeg/HEAD --enable-shared --enable-gpl --enable-version3 --enable-nonfree --enable-hardcoded-tables --enable-libfreetype --cc=/usr/bin/clang --host-cflags='-Os -w -pipe -march=native -Qunused-arguments -mmacosx-version-min=10.8' --host-ldflags='-L/usr/local/Cellar/gettext/0.18.1.1/lib -L/usr/local/lib -L/opt/X11/lib' --enable-libx264 --enable-libfaac --enable-libmp3lame --enable-librtmp --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libass --enable-libvo-aacenc --disable-ffplay
  libavutil      51. 70.100 / 51. 70.100
  libavcodec     54. 54.100 / 54. 54.100
  libavformat    54. 25.104 / 54. 25.104
  libavdevice    54.  2.100 / 54.  2.100
  libavfilter     3. 11.101 /  3. 11.101
  libswscale      2.  1.101 /  2.  1.101
  libswresample   0. 15.100 /  0. 15.100
  libpostproc    52.  0.100 / 52.  0.100
Guessed Channel Layout for  Input Stream #0.0 : mono
Input #0, flv, from 'C773A907-F99C-7AFE-F457-C49B1CC07679.flv':
  Metadata:
    canSeekToEnd    : false
    createdby       : FMS 4.5
    creationdate    : Thu Jul 26 14:45:06 2012
  Duration: 00:00:15.08, start: 0.000000, bitrate: 23 kb/s
    Stream #0:0: Audio: speex, 16000 Hz, mono
[graph 0 input from stream 0:0 @ 0x7fd03842dd20] Invalid sample format '(null)'
Error opening filters!

Attachments (1)

C773A907-F99C-7AFE-F457-C49B1CC07679.flv (43.4 KB) - added by bbhoss 7 years ago.
example file

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by bbhoss

example file

comment:1 Changed 7 years ago by bbhoss

I actually overlooked that it's not compiled with --enable-libspeex, but an IRC user suggested the error reporting could be better.

comment:2 Changed 7 years ago by cehoyos

  • Keywords wav flv removed
  • Resolution set to invalid
  • Status changed from new to closed

Generally, I don't think libavcodec knows if it can't decode a stream because the codec is not supported or because an optional part was not compiled with the library.

But I may of course miss something...

Note: See TracTickets for help on using tickets.