Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1667 closed defect (fixed)

ffplay resizes can cause "garbage" in the margins

Reported by: rogerdpack Owned by: cus
Priority: normal Component: ffplay
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: If you ever "resize" ffplay it doesn't refresh/redraw the margins, which can cause them to be left with garbage:

SDL version: 1.2.15 (windows)

How to reproduce:

$ ffplay sintel.mpg
ffplay version N-43765-g3e9a05f Copyright (c) 2003-2012 the FFmpeg developers
  built on Aug 19 2012 07:54:48 with gcc 4.7.1 (GCC)
  configuration: --enable-memalign-hack --arch=x86 --enable-gpl --enable-libx264 --enable-avisynth --enable-libxvid --target-os=mingw32 --cross-prefix=/home/rogerdpack/dev/ffmpeg-windows-build-helpers/builds/mingw-w64-i686/bin/i686-w64-mingw32- --pkg-config=pkg-config --enable-libmp3lame --enable-version3 --enable-libvo-aacenc --enable-libvpx --extra-libs=-lws2_32 --extra-libs=-lpthread --enable-zlib --extra-libs=-lwinmm --extra-libs=-lgdi32 --enable-librtmp --enable-runtime-cpudetect
  libavutil      51. 70.100 / 51. 70.100
  libavcodec     54. 54.100 / 54. 54.100
  libavformat    54. 25.104 / 54. 25.104
  libavdevice    54.  2.100 / 54.  2.100
  libavfilter     3. 11.101 /  3. 11.101
  libswscale      2.  1.101 /  2.  1.101
  libswresample   0. 15.100 /  0. 15.100
  libpostproc    52.  0.100 / 52.  0.100
[mpeg2video @ 03569E20] ac-tex damaged at 40 7
[mpeg2video @ 03569E20] Warning MVs not available
[mpeg2video @ 03569E20] concealing 1035 DC, 1035 AC, 1035 MV errors in I frame
[mpeg @ 03556680] max_analyze_duration 5000000 reached at 5024000
Input #0, mpeg, from 'sintel.mpg':
  Duration: 00:14:47.58, start: 0.233367, bitrate: 4132 kb/s
    Stream #0:0[0x1e0]: Video: mpeg2video (Main), yuv420p, 720x480 [SAR 32:27 DAR 16:9], 7000 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
    Stream #0:1[0x80]: Audio: ac3, 48000 Hz, 5.1(side), s16, 448 kb/s
SDL_OpenAudio (6 channels): DirectSound CreateSoundBuffer: Invalid parameter
SDL_OpenAudio (4 channels): DirectSound CreateSoundBuffer: Invalid parameter
[mpeg2video @ 03569E20] ac-tex damaged at 40 7
[mpeg2video @ 03569E20]    0.22 A-V:-1345487836.351 fd=   0 aq=   10KB vq=   13KWarning MVs not available
[mpeg2video @ 03569E20] concealing 1035 DC, 1035 AC, 1035 MV errors in I frame
Frame changed from size:0x0 to size:720x480
   8.19 A-V: -0.026 fd= 106 aq=   20KB vq=  138KB sq=    0B f=0/0

It happens with any file.

Attachments (2)

sdl.png (358.3 KB) - added by rogerdpack 5 years ago.
example after a free resizes
updaterect.patch (4.3 KB) - added by cus 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by rogerdpack

example after a free resizes

comment:1 Changed 5 years ago by rogerdpack

it occurs when the video is playing, or paused, or still-framed after the input ends.

comment:2 Changed 5 years ago by cehoyos

  • Component changed from undetermined to FFplay
  • Version changed from unspecified to git-master

Could this be Windows-specific?

comment:3 Changed 5 years ago by cus

  • Owner set to cus
  • Status changed from new to open

Changed 5 years ago by cus

comment:4 Changed 5 years ago by cus

Can you try the attached patch?

comment:5 Changed 5 years ago by rogerdpack

that seems to fix it great thanks!

comment:6 Changed 5 years ago by cus

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in git master. Thanks for testing.

comment:7 Changed 5 years ago by rogerdpack

Seems to be working well for me in production, thanks again.

Note: See TracTickets for help on using tickets.