Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1657 closed enhancement (fixed)

Cannot add myself to a bug CC list for e-mail notifications

Reported by: fturco Owned by:
Priority: normal Component: trac
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I just registered myself to this bug tracking system because I'd like to get e-mail notifications for certain interesting bugs, but it seems I can't add myself to a bug CC list.

When modifying a bug, my only options are:

  • leave as new
  • open
  • assign to

Change History (11)

comment:1 Changed 7 years ago by compn

i think you have to have moderator/admin access in the wiki to do that.

but regular users should be allowed to have this feature. i know bugzilla allows it.

comment:2 Changed 7 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed, please reopen if it still does not work.

comment:3 Changed 7 years ago by fturco

  • Resolution fixed deleted
  • Status changed from closed to reopened

Sorry but I still cannot add myself to a bug CC list.

comment:4 Changed 7 years ago by cehoyos

This seems to be a limitation of trac (I added TICKET_EDIT_CC to "authenticated" but that is not enough to allow all authenticated users to add themselves to CC).
Somebody else seems to have found this limitation before: http://old.nabble.com/TICKET_EDIT_CC-td23944307.html

As a workaround, send a message to the ticket that you want be CC'd.

comment:5 follow-up: Changed 7 years ago by fturco

What do you mean by "send a message to the ticket"? Should I add a random comment to the bug? Or should I send an e-mail to a certain special address?

comment:6 in reply to: ↑ 5 Changed 7 years ago by cehoyos

Replying to fturco:

What do you mean by "send a message to the ticket"? Should I add a random comment to the bug?

No, please add a comment to the ticket that you want to be added to CC.

comment:7 Changed 7 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from reopened to closed

Afaict, there is nothing we can do about this problem.

As said, I will add people to CC if they post a message to a ticket that they want to be added.

comment:8 Changed 7 years ago by burek

Maybe offtopic but, have you considered using a different approach, using "View tickets" reporting system and RSS?

If you click on a View tickets link (upper right corner of this page), there should be a link to Custom query, right below that "View tickets" link. Once you create your query and click on the update button, the results will be shown and below, at the bottom of the page, you'll see a small RSS icon, which reflects your query.

These days all modern e-mail clients have a support for RSS too, so it can easily be integrated into existing system you use. That way you'll get your updates for new tickets that fall under your query restrictions.

For per-ticket notifications, each ticket has got (also at the bottom of the page) its own RSS link, which you can use the same way.

comment:9 Changed 7 years ago by fturco

I don't like RSS feeds, for several reasons, the main one being that they usually give you the latest N items, and if it happens that you don't check the feed for weeks and in the meantime M items are published, with M > N, then you lose M - N items.

comment:10 Changed 7 years ago by michael

  • Resolution changed from invalid to fixed

Please try again, should be fixed

comment:11 Changed 7 years ago by fturco

Thank you, it seems to work!

Note: See TracTickets for help on using tickets.