Opened 5 years ago

Closed 5 years ago

#1639 closed defect (fixed)

concat filter frozen

Reported by: chinshou Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords: movie
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

The concat filter cause ffmpeg frozen.

prepare any mp4 video , rename it to 1.mp4. then copy it to 2.mp4.

finally execute following command to join the two videos

ffmpeg -f lavfi -i "movie=1.mp4, scale=512:288 [v1] ; amovie=1.mp4 [a1] ;movie=2.mp4, scale=512:288 [v2] ; amovie=2.mp4 [a2] ;[v1] [v2] concat [out0] ; [a1] [a2] concat=v=0:a=1 [out1]" join.avi

ffmpeg begin to encoding successfully , but frozen at 50% .

I used the ffmpeg 20120810 windows build from
http://ffmpeg.zeranoe.com/builds/win32/static/ffmpeg-20120810-git-633b90c-win32-static.7z

I investigate the code and found the frozen caused by av_read_frame , the call will be blocked at 50% position.

Change History (4)

comment:1 Changed 5 years ago by Cigaes

  • Keywords concat added
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Note that it works with -filter_complex.

comment:2 Changed 5 years ago by Cigaes

  • Analyzed by developer set
  • Keywords movie added; concat removed

comment:3 Changed 5 years ago by chinshou

Please close this ticket , it seems the bug has already been fixed , I just test it with the latest ffmpeg commandline without frozen problem.

comment:4 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

For future tickets: Please always post a (failing) command line together with complete, uncut console output.

Note: See TracTickets for help on using tickets.