Opened 4 years ago

Closed 4 years ago

#1617 closed defect (fixed)

Ffmpeg/ffplay/ffprobe fails to identify, open or play ogg (specific, attached) file with flac/theora contents.

Reported by: noname Owned by: ubitux
Priority: important Component: undetermined
Version: git-master Keywords: ogg theora flac regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
ffmpeg/ffplay/ffprobe fails to identify, open or play ogg (specific, attached) file with flac/theora contents.

Note that this does not apply to all ogg+flac/theora files, only the attached one.

File plays in vlc and mplayer.
oggz-info can retrieve stream information.

How to reproduce:

% ffprobe flac+theora.ogg
(attached file)
ffmpeg version git-master
built on ubuntu 12.04/x86_64/gcc 4.6.1

Output from applications:

$ ./ffprobe ~/Downloads/flac+theora.ogg 
ffprobe version N-43327-gaca0f78 Copyright (c) 2007-2012 the FFmpeg developers
  built on Aug  8 2012 10:55:14 with gcc 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
  configuration: 
  libavutil      51. 67.100 / 51. 67.100
  libavcodec     54. 51.100 / 54. 51.100
  libavformat    54. 22.101 / 54. 22.101
  libavdevice    54.  2.100 / 54.  2.100
  libavfilter     3.  6.100 /  3.  6.100
  libswscale      2.  1.101 /  2.  1.101
  libswresample   0. 15.100 /  0. 15.100
[ogg @ 0x2a653c0] Codec not found
    Last message repeated 186 times
[flac @ 0x2a6b880] Invalid media type for video
[ogg @ 0x2a653c0] decoding for stream 0 failed
[ogg @ 0x2a653c0] Could not find codec parameters for stream 0 (Video: theora, 320x240): unspecified pixel format
Consider increasing the value for the 'analyzeduration' and 'probesize' options
/home/noname/Downloads/flac+theora.ogg: Operation not permitted
$ oggz-info ~/Downloads/flac+theora.ogg 
Content-Duration: 00:00:00.000

Flac0: serialno 0000020829
	361 packets in 99 pages, 3.6 packets/page, 1.094% Ogg overhead

Theora: serialno 0000020830
	283 packets in 193 pages, 1.5 packets/page, 1.044% Ogg overhead
	Theora-Version: 3.2.1
	Video-Framerate: 25.000 fps
	Video-Width: 320
	Video-Height: 240

Attachments (1)

flac+theora.ogg (1.2 MB) - added by noname 4 years ago.
Ogg with flac/theora contents that fails to open.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by noname

Ogg with flac/theora contents that fails to open.

comment:1 Changed 4 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Reproduced by developer set
  • Status changed from new to open

comment:2 Changed 4 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important

Looks like a regression since 8f3eebd

comment:3 Changed 4 years ago by ubitux

  • Owner set to ubitux

Confirmed, working on it.

Version 0, edited 4 years ago by ubitux (next)

comment:4 Changed 4 years ago by ubitux

  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed in ea5bd7e.

Note: See TracTickets for help on using tickets.