Opened 4 years ago

Closed 3 years ago

#1615 closed enhancement (fixed)

video diff filter

Reported by: ylluminate Owned by:
Priority: wish Component: avfilter
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

It would be useful to have a visual diff tool for videos that will create a resultant differential video of two videos. This could be used in a number of scenarios from simply seeing more easily the differences of one encode to the next to many other applications.

With some overlay+pad magic you should be able to compare img1,img2 and diff on the same image. Similarly should function with vid frames.

It would be useful to have a few different styles of diffing from an outline to color inversion and clipping similar to what is demonstrated here: http://jeffkreeftmeijer.com/2011/comparing-images-and-creating-image-diffs/

Change History (5)

comment:1 Changed 4 years ago by cehoyos

  • Keywords diff difference removed
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

See also ticket #944.

comment:2 Changed 4 years ago by ubitux

There is a vf compare patch on the fork mailing list. Since there is no activity related since a while, someone may want to pick it and make something out of it. It shouldn't require that much work.

comment:3 Changed 4 years ago by richardpl

The compare filters does something completely different and does not looks proper to use it for extending with diff stuff.

diff filter could be just be subset of blend filter.

Version 0, edited 4 years ago by richardpl (next)

comment:4 Changed 4 years ago by richardpl

You can use blend filter : blend=all_mode=difference (among others) or make your own with eval expr, documentation with examples is in usual place.

comment:5 Changed 3 years ago by richardpl

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.