Opened 10 years ago

Closed 10 years ago

#1608 closed defect (fixed)

lxfdec fails to recognize 16 channels

Reported by: GabrielGerard Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: lxf
Cc: Reimar, Döffinger, Tomas, Härdin, Michael, Niedermayer Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:lxf version 1 with 16 tracks created with VR are interpreted as 12 tracks audio channels, with 4 and 8 traks works fine.
How to reproduce: By exemple ffmpeg -i input.lxf -vcodec copy -acodec copy output.mxf

% ffmpeg -i input.lxf -vcodec xx -acodec xx output.xxx
ffmpeg version all the new with version 1 lxf support.
built on ...

Attachments (3)

AdriveShareFiles.txt (1002 bytes ) - added by GabrielGerard 10 years ago.
Links to the files due to the size of them
attachment.png (126.4 KB ) - added by GabrielGerard 10 years ago.
attachment.zip (136.0 KB ) - added by GabrielGerard 10 years ago.

Download all attachments as: .zip

Change History (10)

by GabrielGerard, 10 years ago

Attachment: AdriveShareFiles.txt added

Links to the files due to the size of them

by GabrielGerard, 10 years ago

Attachment: attachment.png added

by GabrielGerard, 10 years ago

Attachment: attachment.zip added

comment:1 by GabrielGerard, 10 years ago

In the example when mxf is created, has 12 channels and the mxf created is corrupted, is possible to play but has wrong video and audio timing.
All the file I sent are true native lxf version 1, you can use to test with trust.

comment:2 by GabrielGerard, 10 years ago

Note: The files from http://titan.codemill.se/~tomhar/samples/lxf/ not all are lxf version 1 native
1.lxf
100723-TAM VAN HOA-00240.lxf
F0015132.lxf
PM4617.lxf
ZB09_108_LXF_V1.lxf
F0000721.lxf
F0015132.lxf
LXF_File_1.lxf

All of them have invalid format when used in VR, 2 channels are not use in native lxf version 1.

comment:3 by GabrielGerard, 10 years ago

Last Mediainfo reports badly 12 chanels too with device and trace, although find the 16 PCM channels inside in basic mode.

comment:4 by Carl Eugen Hoyos, 10 years ago

Keywords: lxfdec removed

Is this also reproducible with current git head?

Please add complete, uncut ffmpeg console output.

comment:5 by Carl Eugen Hoyos, 10 years ago

Reproduced by developer: set
Status: newopen
Version: 0.11.1git-master

Patch on mailing list.

comment:6 by GabrielGerard, 10 years ago

I tested the patch and works fine with "ffmpeg -i input.lxf -vcodec copy -acodec copy output.mxf", the files created have 4,8 or 16 channels and they can be played well.
Please let me now if you need something else.
Thank you

comment:7 by Carl Eugen Hoyos, 10 years ago

Resolution: fixed
Status: openclosed

Thank you for testing and the analysis!

Note: See TracTickets for help on using tickets.