Opened 4 years ago

Closed 4 years ago

#1595 closed defect (invalid)

Theora video produced by latest ffmpeg fails to load in Google Chrome

Reported by: bartbogdan Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: theora regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

When creating a theora video with the latest checkout of ffmpeg (n0.8-12179-g1f68be4), the video fails to load in Google Chrome.
The video loads properly when using the latest stable release 0.11.1.

How to reproduce:

% ffmpeg -i input -qscale 5 -an -vcodec libtheora output

Then try to open the video in Google Chrome (tested on Windows and Linux, v.20.0.1132.57)

FFmpeg version: development branch (git describe: n0.8-12179-g1f68be4), built on 2-8-2012 using libtheora 1.1.0 on RHEL.

Attachments (5)

example-input.avi (723.0 KB) - added by bartbogdan 4 years ago.
example-theora-master.ogg (116.1 KB) - added by bartbogdan 4 years ago.
example-theora-0.11.1.ogg (93.0 KB) - added by bartbogdan 4 years ago.
ffmpeg-master.log (3.9 KB) - added by bartbogdan 4 years ago.
ffmpeg-0.11.1.log (2.9 KB) - added by bartbogdan 4 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords regression added
  • Version changed from unspecified to git-master

Please post complete, uncut console output together with your command line.

Please consider using git bisect to find the change introducing the regression.

Changed 4 years ago by bartbogdan

Changed 4 years ago by bartbogdan

Changed 4 years ago by bartbogdan

Changed 4 years ago by bartbogdan

Changed 4 years ago by bartbogdan

comment:2 follow-up: Changed 4 years ago by cehoyos

In your command line, you do not specify a colour space. Older FFmpeg by default degraded colour information by choosing yuv420p even if the input format is rgb, newer FFmpeg chooses an output colour space that allows for maximum compatibility with the input colour space (see tickets #1426 and #1517).

I suspect it will work fine with -pix_fmt yuv420p - please test.

comment:3 in reply to: ↑ 2 Changed 4 years ago by bartbogdan

Replying to cehoyos:

You are right! Adding -pix_fmt yuv420p produces a working video.
I guess this ticket can be closed. Thanks!

Last edited 4 years ago by bartbogdan (previous) (diff)

comment:4 Changed 4 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Thank you for testing!

Note: See TracTickets for help on using tickets.