Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1594 closed defect (invalid)

Error with convert wmv to flv

Reported by: PR Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: When I tried to convert two videos I see next errors:

Metadata:
    WMFSDKVersion   : 12.0.7601.17514
    WMFSDKNeeded    : 0.0.0.0000
    IsVBR           : 1
  Duration: 00:02:28.78, start: 0.000000, bitrate: 653 kb/s
    Stream #0:0(eng): Video: wmv3 (Main) (WMV3 / 0x33564D57), yuv420p, 980x938,
300 kb/s, 32.25 tbr, 1k tbn, 1k tbc
    Stream #0:1(eng): Audio: wmalossless (c[1][0][0] / 0x0163), 44100 Hz, stereo
, s16, 1152 kb/s
[libvpx @ 01f78620] v1.1.0
[wmv3 @ 0034ce40] Extra data: 8 bits left, value: 0
[flv @ 01f77f40] video codec not compatible with flv
Output #0, flv, to 'C:\Users\MyUser\Desktop\2.flv':
  Metadata:
    WMFSDKVersion   : 12.0.7601.17514
    WMFSDKNeeded    : 0.0.0.0000
    IsVBR           : 1
  Duration: 00:02:28.78, start: 0.000000, bitrate: 653 kb/s
    Stream #0:0(eng): Video: wmv3 (Main) (WMV3 / 0x33564D57), yuv420p, 980x938,
300 kb/s, 32.25 tbr, 1k tbn, 1k tbc
    Stream #0:1(eng): Audio: wmalossless (c[1][0][0] / 0x0163), 44100 Hz, stereo
, s16, 1152 kb/s
[libvpx @ 01f78620] v1.1.0
[wmv3 @ 0034ce40] Extra data: 8 bits left, value: 0
[flv @ 01f77f40] video codec not compatible with flv
Output #0, flv, to 'C:\Users\PRusev\Desktop\2.flv':
  Metadata:
    WMFSDKVersion   : 12.0.7601.17514
    WMFSDKNeeded    : 0.0.0.0000
    IsVBR           : 1
    encoder         : Lavf54.22.100
    Stream #0:0(eng): Video: vp8, yuv420p, 980x938, q=-1--1, 200 kb/s, 90k tbn,
32.25 tbc
    Stream #0:1(eng): Audio: mp3 ([2][0][0][0] / 0x0002), 44100 Hz, stereo, s16
Stream mapping:
  Stream #0:0 -> #0:0 (wmv3 -> libvpx)
  Stream #0:1 -> #0:1 (wmalossless -> libmp3lame)
Could not write header for output file #0 (incorrect codec parameters ?): Operation not permitted

for first video and

[asf @ 003cc420] Could not find codec parameters for stream 0 (Video: none (MSS2
 / 0x3253534D), 698x400, 150 kb/s): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Guessed Channel Layout for  Input Stream #0.1 : mono
Input #0, asf, from 'C:\Users\PRusev\Desktop\1.wmv':
  Metadata:
    WMFSDKVersion   : 11.0.6002.18049
    WMFSDKNeeded    : 0.0.0.0000
    IsVBR           : 0
  Duration: 00:05:15.50, start: 0.000000, bitrate: 118 kb/s
    Stream #0:0(eng): Video: none (MSS2 / 0x3253534D), 698x400, 150 kb/s, 4 tbr,
 1k tbn, 1k tbc
    Stream #0:1(eng): Audio: wmavoice ([10][0][0][0] / 0x000A), 22050 Hz, mono,
flt, 20 kb/s
[buffer @ 041994a0] Unable to parse option value "-1" as pixel format
[graph 0 input from stream 0:0 @ 041e04a0] Error parsing options string: video_s
ize=698x400:pix_fmt=-1:time_base=1/1000:pixel_aspect=0/1:sws_param=flags=2:frame
_rate=4/1
Error opening filters!

for second.

How to reproduce:

% ffmpeg -i input -sameq -vcodec libx264 -ar 22050 -f flv -y output
ffmpeg version
built on ...

Change History (5)

comment:1 Changed 6 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Priority changed from critical to normal
  • Resolution set to invalid
  • Status changed from new to closed

For future errors: Please always provide complete, uncut console output (not an excerpt of the console output) and please do not report multiple issues in one ticket (this makes following the reports impossible), but always open one ticket per issue.

The first issue you report here is invalid, see for example https://ffmpeg.org/trac/ffmpeg/wiki/SupportedMediaTypesInFormats for a list of supported formats in flv (it makes no sense for FFmpeg to mux formats into a flash file that no player would be able to decode).

The second issue is a duplicate of ticket #1230.

comment:2 follow-up: Changed 6 years ago by PR

Thanks, for reply!
So, for first video will be imposible to convert this video, right?
For second - i saw in the ticket #1230 and if I understand, the problem will be solved with 'mencoder', right? But how to use it in console?
Thanks!

comment:3 in reply to: ↑ 2 Changed 6 years ago by cehoyos

Replying to PR:

So, for first video will be imposible to convert this video, right?

Afaict, there is no reason to assume that FFmpeg cannot convert your video.

For second - i saw in the ticket #1230 and if I understand, the problem will be solved with 'mencoder', right?

I would not say that MEncoder "solves" any problem, but I believe MEncoder can decode your sample.

But how to use it in console?

It can only be used "in console"

comment:4 Changed 6 years ago by PR

I'm a little confused...
Is any chance to convert first video?
And what is command for MEncoder?
Thanks!

comment:5 Changed 6 years ago by cehoyos

Please understand that this is not a support forum but a bug tracker. For usage questions about FFmpeg, please post on ffmpeg-user - http://ffmpeg.org/mailman/listinfo/ffmpeg-user - for questions about MEncoder on mencoder-users: http://lists.ffmpeg.org/mailman/listinfo/mencoder-users

Note: See TracTickets for help on using tickets.