Opened 4 years ago

Closed 4 years ago

#1574 closed defect (invalid)

Opening specific MXF files failes

Reported by: shroomM Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mxf
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


Just opening the file fails:

How to reproduce:

ffmpeg -i my_mxf.mxf
ffmpeg version N-42806-gf4451d2 Copyright (c) 2000-2012 the FFmpeg developers
  built on Jul 23 2012 09:08:50 with gcc 4.5.2 (GCC) (x86_64.generic.Komisar)
  configuration: --enable-gpl --enable-version3 --enable-nonfree --disable-hwaccels
--disable-doc --enable-runtime-cpudetect --extra-cflags=-U__STRICT_ANSI__
--extra-cflags=-DPTW32_STATIC_LIB --prefix=/home/vodenc1/software/win64
--cross-prefix=x86_64-pc-mingw32- --cpu=x86_64 --arch=x86_64 --target-os=mingw32
--enable-avisynth --enable-libfaac --enable-libx264 --enable-libmp3lame --enable-libopencore-amrnb
  libavutil      51. 65.100 / 51. 65.100
  libavcodec     54. 44.100 / 54. 44.100
  libavformat    54. 19.100 / 54. 19.100
  libavdevice    54.  2.100 / 54.  2.100
  libavfilter     3.  3.100 /  3.  3.100
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0. 15.100 /  0. 15.100
  libpostproc    52.  0.100 / 52.  0.100
[mxf @ 000000000038F3E0] found essence prior to first PartitionPack
my_mxf.mxf: Invalid data found when processing input

Change History (4)

comment:1 Changed 4 years ago by cehoyos

  • Component changed from undetermined to avformat

Which software plays the sample?

Please provide a sample.

comment:2 Changed 4 years ago by shroomM

Well, I thought it was the latest VLC but it turns out an ancient version of VLC can play it... 1.1.4, The Luggage.

The latest version does NOT play it.

It's a bit hard for me to provide a sample since:

  • it's a copyrighted material
  • it's a 15GB of copyrighted material

Any other ideas how we could solve this?

Version 0, edited 4 years ago by shroomM (next)

comment:3 Changed 4 years ago by shroomM

Please close the ticket, the MXF file was corrupted.

Sorry for the mistake.

comment:4 Changed 4 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

If any software (like old vlc) is able to decode the file, FFmpeg should imo also support it.

But without a sample, this is unlikely to happen.

Note: See TracTickets for help on using tickets.