Opened 4 years ago

Closed 3 years ago

#1507 closed defect (fixed)

Aspect ratio wrong in rv40 video (after resolution change)

Reported by: xyzpublic Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: real rv40
Cc: donmoir@comcast.net Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
Change of dimensions of the source video seems not handled properly by ffmpeg/ffplay(git master) and vlc/2.01

ffmpeg gives scrambled output.
"ffplay -threads 1 src_with_dimension_change.rmvb" works, but ffplay without "-threads 1" doesn't.
vlc silently quits on dimensions change.

How to reproduce:

% ffmpeg -i src_with_dimension_change.rmvb output.avi
ffmpeg git master
built on ubuntu gcc 4.6.3

Attachments (2)

ffmpeg-20120703-173749.log (511.7 KB) - added by xyzpublic 4 years ago.
ffmpeg -report log
Wrong_aspect_after_resolution_change.rmvb (2.4 MB) - added by cehoyos 4 years ago.

Change History (9)

comment:1 Changed 4 years ago by cehoyos

  • Keywords dimensions change removed

To make this a valid ticket, please provide complete uncut console output together with the command line and please provide a sample.

Changed 4 years ago by xyzpublic

ffmpeg -report log

comment:2 Changed 4 years ago by xyzpublic

Version 0, edited 4 years ago by xyzpublic (next)

comment:3 Changed 4 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from ffmpeg gives scrambled video output when dimensions of the src change to Aspect ratio wrong in rv40 video (after resolution change)
[rv40 @ 0x21f2b40] Width/height changing with frame threading is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.

This part is a duplicate of ticket #1312

But the video aspect is wrong after the resolution change, it should be 4:3 but is undefined.

Changed 4 years ago by cehoyos

comment:4 Changed 4 years ago by cehoyos

  • Keywords real added; rmvb removed

comment:5 Changed 4 years ago by cehoyos

Ticket #1550 may be related.

comment:6 Changed 4 years ago by DonMoir

  • Cc donmoir@comcast.net added

There might be a seek problem with the file after resolution change as well. I can't get the file from the above ftp link and need the full file.

comment:7 Changed 3 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Michael, related to / duplicate of ticket #1550.

Note: See TracTickets for help on using tickets.