Opened 6 years ago

Closed 5 years ago

#148 closed defect (fixed)

ffplay and ffmpeg hang-up for "invalid" streams (urls)

Reported by: alexandru_mg3 Owned by:
Priority: normal Component: undetermined
Version: 0.7.1 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Command:
ffplay rtmp://175.41.168.21:1935/2e2cd/nhkworldhd.sdp

This is a regression in 0.7rc1

No hang-up in 0.6x.

Change History (13)

comment:1 Changed 6 years ago by alexandru_mg3

The Bug is not related to the stream format. Any invalid urls generates a Hang-up

comment:2 follow-up: Changed 6 years ago by cehoyos

  • Status changed from new to open

What do you mean with "hang-up"?
Please provide complete, uncut output of ffmpeg for all issues!

comment:3 in reply to: ↑ 2 Changed 6 years ago by alexandru_mg3

Replying to cehoyos:

What do you mean with "hang-up"?
Please provide complete, uncut output of ffmpeg for all issues!

I run the indicated command above on windows:
"hang-up" means that .exe remains blocked and you need to kill the ffplay from the task manager.

please run the command that I indicated and confirm me that you can reproduce the "hang-up"

comment:4 Changed 6 years ago by cehoyos

I cannot reproduce your problem.

Please provide complete, uncut output of ffmpeg for all issues!

comment:5 Changed 6 years ago by cehoyos

Complete, uncut output:

$ ffmpeg -i rtmp://175.41.168.21:1935/2e2cd/nhkworldhd.sdp
ffmpeg version git-N-29577-gc402ce4, Copyright (c) 2000-2011 the FFmpeg developers
  built on May  3 2011 16:53:01 with gcc 4.5.2
  configuration: --cc='/usr/local/gcc-4.5.2/bin/gcc -m32' --enable-gpl
  libavutil    51.  2. 0 / 51.  2. 0
  libavcodec   53.  3. 0 / 53.  3. 0
  libavformat  53.  0. 3 / 53.  0. 3
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2.  4. 0 /  2.  4. 0
  libswscale    0. 14. 0 /  0. 14. 0
[rtmp @ 0x8c91020] Cannot open connection tcp://175.41.168.21:1935
rtmp://175.41.168.21:1935/2e2cd/nhkworldhd.sdp: Input/output error
$ ffplay rtmp://175.41.168.21:1935/2e2cd/nhkworldhd.sdp
ffplay version git-N-29577-gc402ce4, Copyright (c) 2003-2011 the FFmpeg developers
  built on May  3 2011 16:53:01 with gcc 4.5.2
  configuration: --cc='/usr/local/gcc-4.5.2/bin/gcc -m32' --enable-gpl
  libavutil    51.  2. 0 / 51.  2. 0
  libavcodec   53.  3. 0 / 53.  3. 0
  libavformat  53.  0. 3 / 53.  0. 3
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2.  4. 0 /  2.  4. 0
  libswscale    0. 14. 0 /  0. 14. 0
[rtmp @ 0x8cd4340] Cannot open connection tcp://175.41.168.21:1935
rtmp://175.41.168.21:1935/2e2cd/nhkworldhd.sdp: Input/output error

comment:6 Changed 6 years ago by alexandru_mg3

I can add important details to reproduce the bug:


a) Current Command that reproduce the issue: ffplay http://webtv.moldtelecom.md:81/trm1.flv

b)I have identify the function that generates the hang-up:

is in ffplay.c:

"... err = av_open_input_file(&ic, is->filename, is->iformat, 0, ap);"

c) The execution remains "suspended" in this function for 10 MINUTES: after this time I have killed the ffplay process (I know is incredible but I put the clock to count the minutes)

d) Note: the valid stream and invalid address streams don't generate the hang-up

Please if you can fix this is a very embarassing bug...seems that it was Ok, in 0.6x version.

Thanks.

comment:7 follow-up: Changed 6 years ago by cehoyos

Did you already post complete, uncut output of the command you are using?

$ ffmpeg -i http://webtv.moldtelecom.md:81/trm1.flv
ffmpeg version git-N-30023-g7e5cb2e, Copyright (c) 2000-2011 the FFmpeg developers
  built on May 18 2011 23:44:51 with gcc 4.5.3
  configuration: --cc='/usr/local/gcc-4.5.3/bin/gcc -m32' --enable-gpl
  libavutil    51.  2. 1 / 51.  2. 1
  libavcodec   53.  6. 0 / 53.  6. 0
  libavformat  53.  1. 0 / 53.  1. 0
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2.  5. 0 /  2.  5. 0
  libswscale    0. 14. 0 /  0. 14. 0
  libpostproc  51.  2. 0 / 51.  2. 0
http://webtv.moldtelecom.md:81/trm1.flv: Input/output error
$ ffplay http://webtv.moldtelecom.md:81/trm1.flv
ffplay version git-N-30023-g7e5cb2e, Copyright (c) 2003-2011 the FFmpeg developers
  built on May 18 2011 23:44:51 with gcc 4.5.3
  configuration: --cc='/usr/local/gcc-4.5.3/bin/gcc -m32' --enable-gpl
  libavutil    51.  2. 1 / 51.  2. 1
  libavcodec   53.  6. 0 / 53.  6. 0
  libavformat  53.  1. 0 / 53.  1. 0
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2.  5. 0 /  2.  5. 0
  libswscale    0. 14. 0 /  0. 14. 0
  libpostproc  51.  2. 0 / 51.  2. 0
http://webtv.moldtelecom.md:81/trm1.flv: Input/output error

comment:8 in reply to: ↑ 7 Changed 6 years ago by alexandru_mg3

Replying to cehoyos:

Did you already post complete, uncut output of the command you are using?

$ ffmpeg -i http://webtv.moldtelecom.md:81/trm1.flv

Hello Cehoyos, I tested with ffplay 0.7x.
Please indicate me the ffplay command line parameters to can generate the uncut output that is needed.
This will help me also to supply all the information in the future.

Many Thanks.

comment:9 Changed 6 years ago by cehoyos

Type your command, copy both what you typed and how ffmpeg/ffplay responded, and paste it here (in the tracker), as I did (note that it seems I cannot reproduce your problem). Without it, every report is invalid (because we need the complete, uncut output to understand the problem)!

comment:10 Changed 6 years ago by saste

Maybe the problem is related to the Windows/MinGW network stack, I can't reproduce it in Linux.

comment:11 follow-up: Changed 6 years ago by cehoyos

How do you know the OP tests on Windows?

comment:12 in reply to: ↑ 11 Changed 5 years ago by michael

Replying to cehoyos:

How do you know the OP tests on Windows?

he spoke about .exe

comment:13 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed
  • Version changed from 0.7-rc1 to 0.7.1

Seems to be fixed.

$ ./ffplay.exe rtmp://175.41.168.21:1935/2e2cd/nhkworldhd.sdp
ffplay version 0.7, Copyright (c) 2003-2011 the FFmpeg developers
  built on Jun 25 2011 15:58:07 with gcc 4.5.2
  configuration: --disable-yasm --extra-cflags=-I/usr/include/SDL
  libavutil    51. 10. 0 / 51. 10. 0
  libavcodec   53.  7. 0 / 53.  7. 0
  libavformat  53.  4. 0 / 53.  4. 0
  libavdevice  53.  1. 1 / 53.  1. 1
  libavfilter   2. 23. 0 /  2. 23. 0
  libswscale    2.  0. 0 /  2.  0. 0
[rtmp @ 031e1720] Cannot open connection tcp://175.41.168.21:1935
rtmp://175.41.168.21:1935/2e2cd/nhkworldhd.sdp: Input/output error

$ ./ffmpeg.exe -i rtmp://175.41.168.21:1935/2e2cd/nhkworldhd.sdp
ffmpeg version 0.7, Copyright (c) 2000-2011 the FFmpeg developers
  built on Jun 25 2011 15:58:07 with gcc 4.5.2
  configuration: --disable-yasm --extra-cflags=-I/usr/include/SDL
  libavutil    51. 10. 0 / 51. 10. 0
  libavcodec   53.  7. 0 / 53.  7. 0
  libavformat  53.  4. 0 / 53.  4. 0
  libavdevice  53.  1. 1 / 53.  1. 1
  libavfilter   2. 23. 0 /  2. 23. 0
  libswscale    2.  0. 0 /  2.  0. 0
[rtmp @ 01171ec0] Cannot open connection tcp://175.41.168.21:1935
rtmp://175.41.168.21:1935/2e2cd/nhkworldhd.sdp: Input/output error
Note: See TracTickets for help on using tickets.