Opened 5 years ago

Closed 5 years ago

#1473 closed defect (fixed)

ffplay: mp3 with multiple APICs

Reported by: ami_stuff Owned by:
Priority: normal Component: ffplay
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

FFplay does not cycle(display) new image when "v" key is pressed.

http://www.datafilehost.com/download-5d5cc50f.html

C:\>ffplay multiple_apics.mp3
ffplay version N-41578-ga5c1a0c Copyright (c) 2003-2012 the FFmpeg developers
  built on Jun 13 2012 22:34:53 with gcc 4.6.3
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-ru
ntime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libass
 --enable-libcelt --enable-libopencore-amrnb --enable-libopencore-amrwb --enable
-libfreetype --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libope
njpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libth
eora --enable-libutvideo --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-
libvorbis --enable-libvpx --ena  libavutil      51. 58.100 / 51. 58.100
  libavcodec     54. 25.100 / 54. 25.100
  libavformat    54.  6.101 / 54.  6.101
  libavdevice    54.  0.100 / 54.  0.100
  libavfilter     2. 79.100 /  2. 79.100
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0. 15.100 /  0. 15.100
  libpostproc    52.  0.100 / 52.  0.100
[mp3 @ 0225d800] Format mp3 detected only with low score of 24, misdetection pos
sible!
[mp3 @ 0225d800] max_analyze_duration 5000000 reached at 5015510
Input #0, mp3, from 'multiple_apics.mp3':
  Metadata:
    title           : title
    album           : album
    artist          : artist
    encoder         : Lavf54.6.101
    genre           : Acid Punk
    track           : 1
    date            : 1999
  Duration: 00:00:10.05, start: 0.000000, bitrate: 2117 kb/s
    Stream #0:0: Audio: mp3, 44100 Hz, stereo, s16, 128 kb/s
    Stream #0:1: Video: png, rgb24, 640x480, 90k tbr, 90k tbn, 90k tbc
    Metadata:
      title           : studio logo
      comment         : Publisher/Studio logotype
    Stream #0:2: Video: mjpeg, yuvj420p, 320x240, 90k tbr, 90k tbn, 90k tbc
    Metadata:
      title           : other
      comment         : Other
    Stream #0:3: Video: png, rgb24, 1024x768, 90k tbr, 90k tbn, 90k tbc
    Metadata:
      title           : illustration
      comment         : Illustration
    Stream #0:4: Video: mjpeg, yuvj420p, 1024x768, 90k tbr, 90k tbn, 90k tbc
    Metadata:
      title           : cover
      comment         : Cover (front)
[src @ 0228ca80] Flat options syntax is deprecated, use key=value pairs.
[src @ 0228ca80] w:640 h:480 pixfmt:rgb24 tb:1/90000 fr:0/0 sar:0/1 sws_param:
[format @ 0228d3c0] auto-inserting filter 'auto-inserted scaler 0' between the f
ilter 'src' and the filter 'format'
[auto-inserted scaler 0 @ 0228dd20]   w:640 h:480 fmt:rgb24 sar:0/1 -> w:640 h:4
80 fmt:yuv420p sar:0/1 flags:0x4
[src @ 022b2760] Flat options syntax is deprecated, use key=value pairs.0
[src @ 022b2760] w:320 h:240 pixfmt:yuvj420p tb:1/90000 fr:0/0 sar:0/1 sws_param
:
[format @ 022b2d40] auto-inserting filter 'auto-inserted scaler 0' between the f
ilter 'src' and the filter 'format'
[auto-inserted scaler 0 @ 022b3e00] w:320 h:240 fmt:yuvj420p sar:0/1 -> w:320 h:
240 fmt:yuv420p sar:0/1 flags:0x4
  13.21 A-V:  0.102 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0

Change History (6)

comment:1 follow-up: Changed 5 years ago by cehoyos

  • Version changed from unspecified to git-master

(Is the first png intended to look strange?)

I believe this works as expected:
When you press "v", ffplay changes stream and waits for the next frame (that never arrives because all streams only contain of one frame), if you seek to the beginning, the correct (new) stream is shown

I don't know how feasible it is that ffplay shows the last (earlier) frame (instead of the next one) if "v" is pressed.

comment:2 in reply to: ↑ 1 Changed 5 years ago by ami_stuff

Replying to cehoyos:

(Is the first png intended to look strange?)

Yes, it looks correct (in negative).

comment:3 Changed 5 years ago by michael

  • Component changed from undetermined to FFplay

I think this qualifies a ffplay issue

comment:4 Changed 5 years ago by cehoyos

  • Status changed from new to open

comment:5 Changed 5 years ago by michael

patch on ML

comment:6 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Implemented by Michael.

Note: See TracTickets for help on using tickets.