Opened 5 years ago

Closed 5 years ago

#1469 closed defect (invalid)

Timecode too fast after Yadif

Reported by: jangrewe Owned by:
Priority: normal Component: avfilter
Version: 0.11.1 Keywords: yadif, drawtext, timecode
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug: The timecode added through the drawtext videofilter is running at 2x the framerate when yadif is used to deinterlace the source material

How to reproduce:

$ /usr/local/bin/ffmpeg -y -threads 4 -i test.m2v -c:v libx264 -b:v 3072k -vf "yadif=1:1, crop=720:576:0:32, scale=640:480, drawtext=fontfile=/usr/share/fonts/truetype/ttf-bitstream-vera/VeraMono.ttf:fontsize=28:fontcolor=white:box=1:boxcolor=0x000000CC:x=(w-tw)/2:y=h-(2*lh):timecode='00\:00\:00\:00':rate=25" -pix_fmt yuv420p -f mp4 /srv/test.mp4


ffmpeg version 0.11.1
built on Jun 19 2012 16:28:33 with gcc 4.6.3
configuration: --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libx264 --enable-libxvid --enable-nonfree --enable-postproc --enable-libfreetype --enable-version3 --enable-x11grab --enable-libass --enable-fontconfig
libavutil      51. 54.100 / 51. 54.100
libavcodec     54. 23.100 / 54. 23.100
libavformat    54.  6.100 / 54.  6.100
libavdevice    54.  0.100 / 54.  0.100
libavfilter     2. 77.100 /  2. 77.100
libswscale      2.  1.100 /  2.  1.100
libswresample   0. 15.100 /  0. 15.100
libpostproc    52.  0.100 / 52.  0.100

Attachments (1)

test.mp4 (196.7 KB) - added by jangrewe 5 years ago.
sample video with timecode

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by jangrewe

sample video with timecode

comment:1 Changed 5 years ago by ubitux

  • Status changed from new to open

As discussed on IRC, this is reproducible because of the yadif filter, which seems to be calling the end_frame() from drawtext filter too much (→ even when dropping a frame).

@jangrewe: can you provide the source sample so we can reproduce it?

comment:3 Changed 5 years ago by michael

yadif=1:1 turns each field (2 per frame) into a frame, thus the rate doubles.

comment:4 Changed 5 years ago by michael

  • Reproduced by developer set
  • Resolution set to invalid
  • Status changed from open to closed

This issue happens because you double the framerate fro, 25 to 50 with yadif but specify 25 to the drawtext filter instead of 50

Note: See TracTickets for help on using tickets.