Opened 4 years ago

Closed 4 years ago

#1420 closed art (invalid)

Summer logo (2012) by Unknown

Reported by: burek Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Attachments (1)

michael_ff_LOGO_monkey07-02-27.jpeg (16.2 KB) - added by burek 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by burek

comment:1 Changed 4 years ago by michael

I did not draw this logo !

comment:2 Changed 4 years ago by michael

  • Description modified (diff)

comment:3 Changed 4 years ago by llogan

  • Resolution set to invalid
  • Status changed from new to closed
  • Summary changed from Summer logo 3 to Summer logo (2012) by Unknown

Closing as invalid due to unknown author.

Note: See TracTickets for help on using tickets.