Opened 7 years ago

Closed 7 years ago

#1390 closed defect (fixed)

mp1 crash on windows

Reported by: ami_stuff Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

crashes also with -acodec mp2/3, but not with float versions

http://www.datafilehost.com/download-6d968fed.html

(gdb) r -acodec mp1 -i test.shn -f null -
Starting program: d:\mingw\msys\1.0\ffmpeg-head-ab7d6cb\ffmpeg_g.exe -acodec mp1
 -i test.shn -f null -
[New Thread 2260.0xf0c]
ffmpeg version 0.10.2.git-ab7d6cb Copyright (c) 2000-2012 the FFmpeg developers
  built on May 30 2012 13:37:47 with gcc 4.6.1
  configuration: --disable-ffprobe --enable-gpl
  libavutil      51. 55.100 / 51. 55.100
  libavcodec     54. 23.100 / 54. 23.100
  libavformat    54.  6.101 / 54.  6.101
  libavdevice    54.  0.100 / 54.  0.100
  libavfilter     2. 77.100 /  2. 77.100
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0. 15.100 /  0. 15.100
  libpostproc    52.  0.100 / 52.  0.100
[mp1 @ 03bbc7c0] Warning: not compiled with thread support, using thread emulati
on
[mp1 @ 03bbc7c0] Header missing
    Last message repeated 661 times
[shn @ 03bb2340] Estimating duration from bitrate, this may be inaccurate
Input #0, shn, from 'test.shn':
  Duration: 00:02:00.86, start: 0.000000, bitrate: 256 kb/s
    Stream #0:0: Audio: mp1, 48000 Hz, mono, s16, 256 kb/s
[pcm_s16le @ 03bbcbc0] Warning: not compiled with thread support, using thread e
mulation
[mp1 @ 03bbc7c0] Warning: not compiled with thread support, using thread emulati
on
Output #0, null, to 'pipe:':
  Metadata:
    encoder         : Lavf54.6.101
    Stream #0:0: Audio: pcm_s16le, 48000 Hz, mono, s16, 768 kb/s
Stream mapping:
  Stream #0:0 -> #0:0 (mp1 -> pcm_s16le)
Press [q] to stop, [?] for help
[mp1 @ 03bbc7c0] Header missing
Error while decoding stream #0:0
[mp1 @ 03bbc7c0] Header missing
Error while decoding stream #0:0
[mp1 @ 03bbc7c0] Header missing
Error while decoding stream #0:0
[mp1 @ 03bbc7c0] Header missing
Error while decoding stream #0:0
[mp1 @ 03bbc7c0] Header missing
Error while decoding stream #0:0
Input stream #0:0 frame changed from rate:48000 fmt:s16 ch:1 chl:mono to rate:44
100 fmt:s16 ch:2 chl:stereo
[aformat @ 03bc1ee0] auto-inserting filter 'auto-inserted resampler 0' between t
he filter 'src' and the filter 'aformat'
[aresample @ 03bc2b40] chl:stereo fmt:s16 r:48000Hz -> chl:mono fmt:s16 r:48000H
z
[abuffer @ 03bc1b60] Changing frame properties on the fly is not supported.
Input stream #0:0 frame changed from rate:44100 fmt:s16 ch:2 chl:stereo to rate:
48000 fmt:s16 ch:2 chl:stereo
[aformat @ 03bc2680] auto-inserting filter 'auto-inserted resampler 0' between t
he filter 'src' and the filter 'aformat'
[aresample @ 03bc21c0] chl:stereo fmt:s16 r:48000Hz -> chl:mono fmt:s16 r:48000H
z
[mp1 @ 03bbc7c0] Header missing
Error while decoding stream #0:0
Input stream #0:0 frame changed from rate:48000 fmt:s16 ch:2 chl:stereo to rate:
44100 fmt:s16 ch:2 chl:stereo
[aformat @ 03bc33c0] auto-inserting filter 'auto-inserted resampler 0' between t
he filter 'src' and the filter 'aformat'

Program received signal SIGSEGV, Segmentation fault.
0x00aa7750 in bessel (x=<optimized out>) at libswresample/resample.c:79
79              t *= x*inv[i];
(gdb) bt
#0  0x00aa7750 in bessel (x=<optimized out>) at libswresample/resample.c:79
#1  build_filter (scale=<optimized out>, phase_count=<optimized out>,
    tap_count=<optimized out>, factor=<optimized out>,
    filter=<optimized out>, c=<optimized out>, type=<optimized out>)
    at libswresample/resample.c:124
#2  swri_resample_init (c=0x3bc48c0, out_rate=48000, in_rate=32000,
    filter_size=16, phase_shift=62671136, linear=16,
    cutoff=0.80000000000000004, format=AV_SAMPLE_FMT_U8)
    at libswresample/resample.c:231
#3  0x00aa4b64 in swr_init (s=0x4115020) at libswresample/swresample.c:246
#4  0x004225b1 in config_output (outlink=0x3bc36a0)
    at libavfilter/af_aresample.c:146
#5  0x00419b01 in avfilter_config_links (filter=0x3bc33c0)
    at libavfilter/avfilter.c:193
#6  0x00419aea in avfilter_config_links (filter=0x3bc3180)
    at libavfilter/avfilter.c:182
#7  0x00418fb8 in ff_avfilter_graph_config_links (log_ctx=<optimized out>,
    graph=<optimized out>) at libavfilter/avfiltergraph.c:144
#8  avfilter_graph_config (graphctx=0x3bc37a0, log_ctx=0x0)
    at libavfilter/avfiltergraph.c:766
#9  0x00406865 in configure_simple_filtergraph (fg=0x3bdbdc0) at ffmpeg.c:1055
#10 0x0040dab1 in configure_filtergraph (fg=<optimized out>) at ffmpeg.c:1421
#11 decode_audio (got_output=<optimized out>, pkt=<optimized out>,
    ist=<optimized out>) at ffmpeg.c:2616
#12 output_packet (ist=0x3bdb7e0, pkt=0x22fbb0) at ffmpeg.c:2813
#13 0x0040e723 in transcode () at ffmpeg.c:3662
#14 0x00b12f42 in main (argc=8, argv=0x3bc0dd0) at ffmpeg.c:5926
(gdb)

Change History (5)

comment:1 Changed 7 years ago by cehoyos

Could you test with current git head? I see no invalid memory accesses here.

comment:2 Changed 7 years ago by ami_stuff

crashes here with (not my build):

C:\>ffmpeg
ffmpeg version N-41228-g0bae666 Copyright (c) 2000-2012 the FFmpeg developers
  built on Jun  2 2012 02:39:18 with gcc 4.5.0 20100414 (Fedora MinGW 4.5.0-1.fc

and

http://ffmpeg.zeranoe.com/builds/win32/static/ffmpeg-20120601-git-8a0efa9-win32-static.7z
(maybe can be reproduced with wine?)

comment:3 Changed 7 years ago by michael

  • Summary changed from mp1 crash to mp1 crash on windows

cant reproduce on linux

comment:4 Changed 7 years ago by michael

Your gdb output is full of "optimized out" can you post one with all optimizations disabled. This could help in identifying where the issue is

comment:5 Changed 7 years ago by ami_stuff

  • Resolution set to fixed
  • Status changed from new to closed

this doesn't crash anymore

Note: See TracTickets for help on using tickets.