Opened 5 years ago

Closed 5 years ago

#1173 closed defect (invalid)

Invalid dts calculation in compute_pkt_fields2

Reported by: Ratio Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

fix in patch

Attachments (1)

0001-frame-delay-calculation-fixed.patch (898 bytes) - added by Ratio 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by Ratio

comment:1 Changed 5 years ago by cehoyos

  • Component changed from avformat to undetermined

Please explain the bug that you are trying to fix:
Please provide the (minimal) ffmpeg command line that allows to reproduce your problem together with complete, uncut console output. A sample might also be needed.

comment:2 Changed 5 years ago by Ratio

This occured when i use libavformat library.
format: matroska
codec: libx264
max_b_frames: 3
has_b_frames: 1

I receive error:
[matroska @ 0418fbe0] Application provided invalid, non monotonically increasing dts to muxer in stream 0: 80 >= 40

When i change has_b_frames to 3, all works fine.

comment:3 Changed 5 years ago by cehoyos

Is the problem also reproducible with ffmpeg (the application)?
If yes, please provide a minimal command line and complete, uncut console output.

comment:4 Changed 5 years ago by Ratio

I just see description for has_b_frames in source code:
"Size of the frame reordering buffer in the decoder."

Parameter name don't match parameter meaning.

All work correctly. Not a bug.

comment:5 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Thank you for the clarification.

Note: See TracTickets for help on using tickets.