Opened 5 years ago

Closed 5 years ago

Last modified 4 months ago

#116 closed defect (fixed)

ffplay - indeo2 code playback regression

Reported by: ami_stuff Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

some gfx bugs while playing the file with ffplay

(easily visible under win32, on amigaos only at the beginning of the playback amd not always -
a quick "broken" image)

most likely libavfilter-caused regression

C:\>ffmpeg -i C:\POTATOI.AVI
FFmpeg version git-N-29181-ga304071, Copyright (c) 2000-2011 the FFmpeg develope
rs
  built on Apr 18 2011 21:24:03 with gcc 4.5.2
  configuration: --enable-gpl --enable-version3 --enable-runtime-cpudetect --ena
ble-memalign-hack --enable-avisynth --enable-bzlib --enable-frei0r --enable-libo
pencore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enable-libgsm --
enable-libmp3lame --enable-libopenjpeg --enable-librtmp --enable-libschroedinger
 --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enabl
e-libx264 --enable-libxavs --enable-libxvid --enable-zlib --cross-prefix=i686-w6
4-mingw32- --target-os=mingw32 --arch=x86_32 --extra-cflags=-I/home/kyle/softwar
e/ffmpeg/external-libraries/win32/include --extra-ldflags=-L/home/kyle/software/
ffmpeg/external-libraries/win32/lib --pkg-config=pkg-config
  libavutil    50. 40. 1 / 50. 40. 1
  libavcodec   52.120. 0 / 52.120. 0
  libavformat  52.108. 0 / 52.108. 0
  libavdevice  52.  4. 0 / 52.  4. 0
  libavfilter   1. 79. 0 /  1. 79. 0
  libswscale    0. 13. 0 /  0. 13. 0
Input #0, avi, from 'C:\POTATOI.AVI':
  Duration: 00:00:08.00, start: 0.000000, bitrate: 2157 kb/s
    Stream #0.0: Video: indeo2, yuv410p, 384x288, 10 tbr, 10 tbn, 10 tbc
At least one output file must be specified

Attachments (1)

POTATOI.AVI (2.1 MB) - added by ami_stuff 5 years ago.

Change History (4)

Changed 5 years ago by ami_stuff

comment:1 Changed 5 years ago by ami_stuff

btw. if someone want a small indeo2 sample archive then i can upload them somewhere (i will delete the files soon if noone want them)

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to git-master

comment:3 Changed 4 months ago by cehoyos

The sample looks visually correct since 73f3c8f73edf0a69502233b2c50fa9e7104f99ec

Note: See TracTickets for help on using tickets.