Opened 5 years ago

Closed 5 years ago

#11 closed defect (fixed)

Some .ape files play only silence in ffplay

Reported by: jlindgren Owned by: michael
Priority: normal Component: ffmpeg
Version: git Keywords: ape
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Forwarded from http://jira.atheme.org/browse/AUD-310. Some .ape files play only silence in ffplay (and likewise in Audacious, which uses FFMPEG as a decoder backend).

This message is printed repeatedly:
[ape @ 0x7f5c08004110] Error decoding frame

Example file:
http://jira.atheme.org/secure/attachment/10593/02+-+Planet.ape

By contrast, this file plays fine in Totem 2.32.0.

$ ffplay
FFplay version git-2611e52, Copyright (c) 2003-2011 the FFmpeg developers

built on Feb 6 2011 10:03:23 with gcc 4.5.2 20110127 (prerelease)
configuration: --prefix=/usr --enable-gpl --enable-libmp3lame --enable-libvorbis --enable-libfaac --enable-libxvid --enable-libx264 --enable-libvpx --enable-libtheora --enable-postproc --enable-shared --enable-x11grab --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libschroedinger --enable-libopenjpeg --enable-version3 --enable-nonfree --enable-runtime-cpudetect --disable-debug
libavutil 50. 36. 0 / 50. 36. 0
libavcore 0. 16. 1 / 0. 16. 1
libavcodec 52.108. 0 / 52.108. 0
libavformat 52. 94. 0 / 52. 94. 0
libavdevice 52. 2. 3 / 52. 2. 3
libavfilter 1. 74. 0 / 1. 74. 0
libswscale 0. 12. 0 / 0. 12. 0
libpostproc 51. 2. 0 / 51. 2. 0

I am willing to test a newer version of FFMPEG if there is reason to believe this has been fixed already.

Change History (1)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in latest git head, thank you for the report!

Note: See TracTickets for help on using tickets.