Opened 5 years ago

Closed 5 years ago

#1091 closed defect (fixed)

libspeex: fail to decode

Reported by: ami_stuff Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: libspeex regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

regression if reproducible

C:\>ffmpeg -i out.ogg out.wav
ffmpeg version N-38817-gc743aad Copyright (c) 2000-2012 the FFmpeg developers
  built on Mar 16 2012 02:32:17 with gcc 4.5.0 20100414 (Fedora MinGW 4.5.0-1.fc
14)
  configuration: --prefix=/var/www/users/research/ffmpeg/snapshots/build --arch=
x86 --target-os=mingw32 --cross-prefix=i686-pc-mingw32- --cc='ccache i686-pc-min
gw32-gcc' --enable-w32threads --enable-memalign-hack --enable-runtime-cpudetect
--enable-cross-compile --enable-static --disable-shared --extra-libs='-lws2_32 -
lwinmm' --extra-cflags='--static -I/var/www/users/research/ffmpeg/snapshots/buil
d/include' --extra-ldflags='-static -L/var/www/users/research/ffmpeg/snapshots/b
uild/lib' --enable-bzlib --enable-zlib --enable-gpl --enable-version3 --enable-n
onfree --enable-libx264 --enable-libspeex --enable-libtheora --enable-libvorbis
--enable-libfaac --enable-libxvid --enable-libopencore-amrnb --enable-libopencor
e-amrwb --enable-libmp3lame --enable-libvpx --disable-decoder=libvpx
  libavutil      51. 42.100 / 51. 42.100
  libavcodec     54. 10.100 / 54. 10.100
  libavformat    54.  2.100 / 54.  2.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 64.101 /  2. 64.101
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  7.100 /  0.  7.100
  libpostproc    52.  0.100 / 52.  0.100
Input #0, ogg, from 'out.ogg':
  Duration: 00:00:00.00, start: 0.010906, bitrate: -2147483 kb/s
    Stream #0:0: Audio: speex, 32000 Hz, 2 channels, s16
    Metadata:
      ENCODER         : Lavf54.2.100
Output #0, wav, to 'out.wav':
  Metadata:
    encoder         : Lavf54.2.100
    Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 32000 Hz, 2 channels,
 s16, 1024 kb/s
    Metadata:
      ENCODER         : Lavf54.2.100
Stream mapping:
  Stream #0:0 -> #0:0 (libspeex -> pcm_s16le)
Press [q] to stop, [?] for help
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
Error while decoding stream #0:0
[libspeex @ 0x1d8a0e0] get_buffer() failed
size=       0kB time=00:00:00.00 bitrate=   0.0kbits/s
video:0kB audio:0kB global headers:0kB muxing overhead inf%
Output file is empty, nothing was encoded (check -ss / -t / -frames parameters i
f used)

Attachments (1)

out.ogg (4.1 KB) - added by ami_stuff 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by ami_stuff

comment:1 Changed 5 years ago by cehoyos

  • Keywords libspeex regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

comment:2 Changed 5 years ago by cehoyos

Regression since 85469f ("Do not set AVCodecContext.frame_size for libspeex, it is not necessary").

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.