Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1021 closed defect (invalid)

ffmpeg goes berserk when trying to convert this video to mjpeg

Reported by: matteosistisette Owned by:
Priority: normal Component: ffmpeg
Version: 0.7.10 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

With the attached video (which is a 3gp video of 20 seconds, 10 fps, 480x640 resolution, h264 codec, for a file size of about 4 MB, I tried the following command:

ffmpeg -i VIDEO0024.3gp -vcodec mjpeg -s 300x400 -qmin 0.8 -qmax 0.8 VIDEO0024.mov

After several minutes, ffmpeg had processed more than 145357 frames, reported a time of 1.62 seconds, had written more than one GIGABYTE of output and was still working. I obviously killed it.

It looks like it gets the framerate completely wrong.

The exactly same command has worked just fine with other video files encoded with other codecs.

ffmpeg version 0.7.3-4:0.7.3-0ubuntu0.11.10.1, Copyright (c) 2000-2011 the Libav developers

built on Jan 4 2012 16:21:50 with gcc 4.6.1

Change History (9)

comment:1 Changed 4 years ago by matteosistisette

Well please let me know how I can attach a file of 4.4MB. There seems to be a limit of 2MB for attachments.

comment:2 Changed 4 years ago by matteosistisette

Adding the option -r 10 for output fixes the issue.
So the problem is not that it is GETTING the wrong fps (it detects 9.91 which is correct), the problem is that it is SETTING the wrong default frame rate for output: about 90000 fps, a totally ridiculous default value.

comment:3 Changed 4 years ago by richardpl

  • Priority changed from critical to normal
  • Resolution set to invalid
  • Status changed from new to closed

This:

fmpeg version 0.7.3-4:0.7.3-0ubuntu0.11.10.1, Copyright (c) 2000-2011 Libav developers

means you are reporting problem to the wrong trac.

comment:4 Changed 4 years ago by reimar

Just to clarify: Did someone test with FFmpeg? I am quite sure this issue has existed at some point in FFmpeg but has been fixed since quite a while.
Which means that just grabbing the latest FFmpeg (_FFmpeg_, not _Libav_) version and compiling it should result in a working binary.

comment:5 Changed 4 years ago by matteosistisette

Wrong trac? Which is the right bug tracker then?

When I copied and pasted the output I missed the first "f" but it reads "ffmpeg".

I installed ffmpeg as a package called "ffmpeg" in Ubuntu through synaptic. Are you saying that the package called "ffmpeg" is actually not ffmpeg??

comment:6 Changed 4 years ago by reimar

Correct, Ubuntu does no longer provide FFmpeg but only a fork called "Libav", and the package called "ffmpeg" is not FFmpeg anymore.

comment:7 Changed 4 years ago by matteosistisette

Oh I see

comment:8 Changed 4 years ago by cehoyos

Also note that the Ubuntu package is known to contain several hundred regressions over FFmpeg, some of them security relevant.

comment:9 Changed 4 years ago by matteosistisette

And why exactly do they distribute such a broken version of ffmpeg if there's one that works better?

Note: See TracTickets for help on using tickets.