Opened 8 years ago

Closed 7 years ago

#1015 closed defect (needs_more_info)

Encode/Decode issues with ProRes 444 Sample

Reported by: rexbron Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: prores
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Sample is available from: http://files.aehunter.net/DIVISION_SAMPLE.mov

As the sample is only 10MB, it likely consists of only pre-roll (bars and tone and a sync countdown).

Couple of things I noticed (log: http://pastebin.ca/2120881)

1) Copying the video stream in to a new (shorter) file results in the wrong pix_fmt when probed. yuv422p10le instead of yuv444p10le.

2) Duration of the original file is reported incorrectly. 00:10:39.88 instead of aprox 15 min.

Finally, output from ffmpeg results in garbage image data and severely out of sync audio.

Change History (7)

comment:1 Changed 8 years ago by richardpl

ffprobe version git-2012-02-22-b0b4fb2 Copyright (c) 2007-2012 the FFmpeg developers
  built on Feb 22 2012 22:48:27 with clang 3.0 (tags/RELEASE_30/final 145349)
  configuration: --cc=clang --as=clang --extra-cflags=-I/usr/local/include --extra-ldflags=-L/usr/local/lib --disable-indev=alsa --disable-outdev=alsa --enable-libx264 --enable-libmp3lame --enable-libschroedinger --enable-gpl --enable-x11grab --enable-shared --disable-static --disable-indev=bktr --enable-openssl --enable-nonfree
  libavutil      51. 40.100 / 51. 40.100
  libavcodec     54.  4.100 / 54.  4.100
  libavformat    54.  1.100 / 54.  1.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 62.101 /  2. 62.101
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  7.100 /  0.  7.100
  libpostproc    52.  0.100 / 52.  0.100
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x29c41100] moov atom not found
/tmp/DIVISION_SAMPLE.mov: Invalid data found when processing input

Provided sample is useless.

comment:2 Changed 8 years ago by rexbron

Sample was created as per instructions on http://ffmpeg.org/bugreports.html. Instructions are useless. </s>

On a more serious note, I will trim a sample using Quicktime on a Final Cut editing station and upload. Looks like using dd doesn't work for movs.

comment:3 follow-up: Changed 8 years ago by compn

oops, yeah, you cant play incomplete movs. we should update the instructions...

comment:4 in reply to: ↑ 3 ; follow-up: Changed 8 years ago by cehoyos

Replying to compn:

oops, yeah, you cant play incomplete movs. we should update the instructions...

Why?
I believe it is pretty obvious that only samples that allow to reproduce the problem make sense. We only request to shorten samples (which is very often very useful) if they are uploaded to our server which is not the case here. And finally, I always explain on this tracker that you have to run tools/qt-faststart before cutting mov files.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 8 years ago by rexbron

Replying to cehoyos:

Replying to compn:

oops, yeah, you cant play incomplete movs. we should update the instructions...

Why?
I believe it is pretty obvious that only samples that allow to reproduce the problem make sense. We only request to shorten samples (which is very often very useful) if they are uploaded to our server which is not the case here. And finally, I always explain on this tracker that you have to run tools/qt-faststart before cutting mov files.

I had no idea that tool existed nor its use for debugging. That would be helpful on the bug reporting page. Wouldn't that save you from having to explain that on the tracker?

If the sample need to be uploaded to your ftp, I will happily do so.

comment:6 in reply to: ↑ 5 Changed 8 years ago by cehoyos

Replying to rexbron:

I had no idea that tool existed nor its use for debugging. That would be helpful on the bug reporting page. Wouldn't that save you from having to explain that on the tracker?

If the sample need to be uploaded to your ftp, I will happily do so.

Please upload the complete sample (or use tools/qt-faststart to prepare your mov sample for cutting).

comment:7 Changed 7 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen the ticket if you can provide a sample.

Note: See TracTickets for help on using tickets.