Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#10011 closed defect (invalid)

xfade produces invalid video files

Reported by: rb1234 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


Summary of the bug:
The xfade filter consistently produces video files that are not universally playable, I've tried it with several different input videos and output formats with the same result each time.

Windows 10 Explorer doesn't show a thumbnail for the result file, and Windows Media Player simply shows a black screen when the output file is loaded; no video, no audio. The output video does play correctly in VLC 3.0.17.

How to reproduce:

% ffmpeg.exe -report -i aqua.mp4 -i fox.mp4 -filter_complex xfade=duration=1:offset=4 xfadetest.mp4
ffmpeg version N-108931-g4dda3b1653-20221104
built with gcc 12.2.0 (crosstool-NG

Attachments (2)

ffmpeg-20221105-012103.log (1.7 MB ) - added by rb1234 18 months ago.
-report result file
ffprobe - invalid video produced by xfade.txt (2.8 KB ) - added by rb1234 18 months ago.

Download all attachments as: .zip

Change History (5)

by rb1234, 18 months ago

Attachment: ffmpeg-20221105-012103.log added

-report result file

comment:1 by Elon Musk, 18 months ago

Resolution: invalid
Status: newclosed

Files are valid.

Your players are not supporting all features.

Use format=yuv420p as last filter in chain for obsolete and ugly players.

comment:2 by Carl Eugen Hoyos, 18 months ago

Keywords: xfade removed

comment:3 by rb1234, 18 months ago

format=yuv420p doesn't seem to make it work with WMP, but I did get it to work by using -vcodec mpeg4

Note: See TracTickets for help on using tickets.