Changes between Version 93 and Version 94 of CompilationGuide/Ubuntu


Ignore:
Timestamp:
Apr 16, 2014, 9:45:12 PM (5 years ago)
Author:
llogan
Comment:

add ffmpeg configure options required for each library. yasm notes.

Legend:

Unmodified
Added
Removed
Modified
  • CompilationGuide/Ubuntu

    v93 v94  
    4545=== Yasm ===
    4646
    47 The first step is to compile Yasm which is an assembler used by x264 and FFmpeg. Ubuntu 13.10, Ubuntu 13.04, and Mint 15 users can alternatively install the `yasm` package from the repository instead of compiling.
     47An assembler for x86 optimizations used by x264 and FFmpeg. Highly recommended or your resulting build may be very slow.
     48
     49If your repository offers a `yasm` package ≥ 1.2.0 then you can install that instead of compiling:
     50
     51{{{
     52sudo apt-get install yasm
     53}}}
     54
     55Otherwise you can compile:
    4856
    4957{{{
     
    6169=== libx264 ===
    6270
    63 H.264 video encoder. See the [[x264EncodingGuide|x264 Encoding Guide]] for more information and usage examples. '''NOTE:''' FFmpeg's ./configure requires --enable-libx264 and --extra-libs="-ldl".
     71H.264 video encoder. See the [[x264EncodingGuide|x264 Encoding Guide]] for more information and usage examples.
     72
     73Requires `ffmpeg` to be configured with `--enable-gpl` `--enable-libx264` `--extra-libs=-ldl`.
    6474
    6575{{{
     
    7787
    7888AAC audio encoder. See the [[AACEncodingGuide|AAC Encoding Guide]] for more information and usage examples.
     89
     90Requires `ffmpeg` to be configured with `--enable-libfdk_aac` (and `--enable-nonfree` if you also included `--enable-gpl`).
    7991
    8092{{{
     
    94106MP3 audio encoder.
    95107
    96 Most users can install the repository package:
     108Requires `ffmpeg` to be configured with `--enable-libmp3lame`.
     109
     110If your repository offers a `libmp3lame-dev` package ≥ 3.98.3 then you can install that instead of compiling:
    97111
    98112{{{
     
    100114}}}
    101115
    102 Ubuntu 10.04 and Debian Squeeze users must compile:
     116Debian 6 "Squeeze" users must compile:
    103117
    104118{{{
     
    118132Opus audio decoder and encoder.
    119133
     134Requires `ffmpeg` to be configured with `--enable-libopus`.
     135
    120136{{{
    121137cd ~/ffmpeg_sources
     
    132148
    133149VP8/VP9 video encoder and decoder. See the [[vpxEncodingGuide|vpx (WebM) Encoding Guide]] for more information and usage examples.
     150
     151Requires `ffmpeg` to be configured with `--enable-libvpx`.
    134152
    135153{{{