Opened 8 years ago

Closed 6 years ago

#906 closed defect (worksforme)

trying to launch ffserver, I get bind(port 8090): Address family not supported by protocol

Reported by: tpereira Owned by:
Priority: normal Component: ffserver
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Im trying to launch ffserver with the original ffserver.conf and I get:

bind(port 8090): Address family not supported by protocol
Mon Jan 9 20:07:23 2012 Could not start server

I recently changed from 2.6.28 to 3.0.6 kernel, and cannot find out which module I need for ffserver to work. IPV4 is working.

Exact command line: ffserver -f ./ffserver.conf -loglevel 'debug'

Output of ffmpeg -v 9 -loglevel 99
ffmpeg version 0.7.8, Copyright (c) 2000-2011 the FFmpeg developers

built on Jan 9 2012 19:25:26 with gcc 4.5.3
configuration: --prefix=/usr --libdir=/usr/lib --shlibdir=/usr/lib --mandir=/usr/share/man --enable-shared --cc=gcc --disable-static --enable-gpl --enable-postproc --enable-avfilter --disable-stripping --disable-debug --disable-doc --disable-vaapi --disable-vdpau --enable-libtheora --enable-libx264 --enable-libxvid --disable-indev=v4l --disable-indev=oss --disable-indev=jack --enable-x11grab --disable-outdev=oss --enable-libfreetype --enable-pthreads --enable-libdirac --enable-librtmp --enable-libschroedinger --disable-altivec --disable-avx --cpu=pentium4 --enable-hardcoded-tables
libavutil 50. 43. 0 / 50. 43. 0
libavcodec 52.123. 0 / 52.123. 0
libavformat 52.111. 0 / 52.111. 0
libavdevice 52. 5. 0 / 52. 5. 0
libavfilter 1. 80. 0 / 1. 80. 0
libswscale 0. 14. 1 / 0. 14. 1
libpostproc 51. 2. 0 / 51. 2. 0

Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Attachments (1)

ffserver_bind.patch (503 bytes) - added by alex_ac 8 years ago.
Patch for current master branch.

Download all attachments as: .zip

Change History (5)

comment:1 in reply to: ↑ description Changed 8 years ago by michael

Replying to tpereira:

Output of ffmpeg -v 9 -loglevel 99
ffmpeg version 0.7.8, Copyright (c) 2000-2011 the FFmpeg developers

This version is a bit old, could you try git master ?

Changed 8 years ago by alex_ac

Patch for current master branch.

comment:2 Changed 8 years ago by alex_ac

I got another message "bind(port 8090): Invalid argument" on the same version of ffmpeg. This message depends of libc version. I found the way to fix it. I has not tested this on "master" branch but it has not been fixed in the source yet.

I attach the patch. Same way works for ffmpeg-0.7.8.

Sorry for my english. It is not my native language.

comment:3 Changed 7 years ago by cehoyos

  • Keywords bind address family not supported protocol removed
  • Status changed from new to open

The patch still applies cleanly but was not applied, sorry;-(

Could you confirm that it is still needed?

comment:4 Changed 6 years ago by michael

  • Resolution set to worksforme
  • Status changed from open to closed

cant reproduce the issue, also AF_INET is set later so the patch should (with current ffserver) make no difference

Note: See TracTickets for help on using tickets.