Opened 3 months ago

Closed 8 weeks ago

#8449 closed defect (needs_more_info)

FFmpeg failed to run sub-microdvd-remux test on release|x86 and debug|x86 configuration with VS2017 on windows

Reported by: KarenHuang Owned by:
Priority: normal Component: fate
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
FFmpeg failed to run sub-microdvd-remux test on release|x86 and debug|x86 configuration with VS2017 on windows. This issue can be reproduced from master revision e20c6d9. Could you please help take a look at this? Thank you!
Steps to reproduce:
1.git clone ​​​​https://github.com/FFmpeg/FFmpeg.git D:\FFmpeg\src
2.Open a VS 2017 x86 prompt and browse to D:\FFmpeg
3.set FFMPEG_TARGET=i386
4.set FFMPEG_SRC_PATH=D:\FFmpeg/src
5.set FFMPEG_FATE_PATH=../fate-suite/
6.set PATH=D:\FFmpeg\tools;%PATH%
7.set MSYS2_PATH_TYPE=inherit
8..\tools\msys32\usr\bin\sh.exe --login -i -c "/D/ffmpeg/tools/build.sh"
9..\tools\msys32\usr\bin\sh.exe --login -i -c "/D/ffmpeg/tools/test.sh"

Actual result:
+{4800}{}...to the end of the presentation
TEST sub-cc-scte20
TEST sub-ass-to-ass-transcode
TEST sub-ssa-to-ass-remux
TEST sub-jacosub
Test sub-microdvd-remux failed. Look at tests/data/fate/sub-microdvd-remux.err for details.
make: * [tests/Makefile:251: fate-sub-microdvd-remux] Error 1
make:
* Waiting for unfinished jobs....
TEST sub-microdvd
Failed FATE test suite!
[command took 212 seconds]

Attachments (1)

log_x86_test.log (77.7 KB) - added by KarenHuang 3 months ago.
log_x86_test

Download all attachments as: .zip

Change History (7)

Changed 3 months ago by KarenHuang

log_x86_test

comment:1 Changed 3 months ago by mkver

The only possible culprit for this is commit 9bde6c6be0ea568f6ce646690616a0d4274095d4 (being the only thing that changed for microdvd in the last time). That patch required to update the ref file, but that should have happened automatically when you received the commit. Given that this patch caused no problems whatsoever with other FATE boxes (even those on Visual Studio (see here), I would like to take a look at all the sub-microdvd-remux files in your tests/data/fate folder.

comment:2 Changed 3 months ago by mkver

Actually, 39561bbe77626458b28f186d03a2ba273d55b655 could also be the cause. Or both taken together.

comment:3 Changed 3 months ago by cehoyos

Are you sure that \n is always one byte? I ask because patches were rejected in the past arguing that it can be longer.

comment:4 Changed 2 months ago by rbultje

Comment on IRC today:

[7:59am] <r57shell>
I dont' wanna register in trac for single comment, but this issue : http://trac.ffmpeg.org/ticket/8449 is caused by different line ending style in ref and result. in ref its \r\n, in result \n only.

comment:5 Changed 2 months ago by cehoyos

Neither tools/build.sh nor tools/test.sh exist in the FFmpeg source tree. I tested fate with both a current VS compiler and gcc on Windows for 32 and 64 Bit and could not reproduce an issue.
Please explain how I can reproduce your issue (without using broken scripts).

comment:6 Changed 8 weeks ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.