Opened 6 months ago

#8090 new defect

RPi 4 h264_mmal error

Reported by: RAJensen Owned by:
Priority: normal Component: avcodec
Version: unspecified Keywords: h264_mmal / h264_omx
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
After update and compile with the latest FFMPEG it now will decode with h264_mmal and encode with h264_omx.
But after 5-6 minutes it will hang.
Also: using v:b 1500k will produce a pixelated background.
If v:b is higher than 3000k it will hang after 2minutes of run.
How to reproduce:

% ffmpeg -ss 00:05:07 -c:v h264_mmal -i 'h264_mmal_test.ts' -to 01:41:44 -map 0:0 -map 0:1 -c:v h264_omx -b:v 3000k -profile:v high -c:a:0 copy 'h264_mmal_test.mp4'
ffmpeg version git-2019-08-20-74e6800 Copyright (c) 2000-2019 the FFmpeg developers
  built with gcc 8 (Raspbian 8.3.0-6+rpi1)
  configuration: --arch=armhf --enable-gpl --enable-nonfree --enable-omx --enable-omx-rpi --enable-mmal
  libavutil      56. 33.100 / 56. 33.100
  libavcodec     58. 55.100 / 58. 55.100
  libavformat    58. 31.101 / 58. 31.101
  libavdevice    58.  9.100 / 58.  9.100
  libavfilter     7. 58.100 /  7. 58.100
  libswscale      5.  6.100 /  5.  6.100
  libswresample   3.  6.100 /  3.  6.100
  libpostproc    55.  6.100 / 55.  6.100
built with gcc 8 (Raspbian 8.3.0-6+rpi1)

Attachments (1)

ffmpeg-20190820-211218.log (2.1 MB) - added by RAJensen 6 months ago.
FFMPEG Logfile

Change History (1)

Changed 6 months ago by RAJensen

FFMPEG Logfile

Note: See TracTickets for help on using tickets.