Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#7743 closed defect (duplicate)

[git master] Build error: ‘tcuGetErrorName’ undeclared (and others)

Reported by: bermond Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm getting the following error when trying to build ffmpeg git master:

CC      libavfilter/vf_scale_cuda.o
In file included from libavfilter/vf_scale_cuda.c:31:
./libavutil/cuda_check.h: In function ‘ff_cuda_check’:
./libavutil/cuda_check.h:38:7: error: ‘tcuGetErrorName’ undeclared (first use in this function); did you mean ‘cuGetErrorName’?
     ((tcuGetErrorName *)cuGetErrorName_fn)(err, &err_name);
       ^~~~~~~~~~~~~~~
       cuGetErrorName
./libavutil/cuda_check.h:38:7: note: each undeclared identifier is reported only once for each function it appears in
./libavutil/cuda_check.h:38:24: error: expected expression before ‘)’ token
     ((tcuGetErrorName *)cuGetErrorName_fn)(err, &err_name);
                        ^
./libavutil/cuda_check.h:39:7: error: ‘tcuGetErrorString’ undeclared (first use in this function); did you mean ‘cuGetErrorString’?
     ((tcuGetErrorString *)cuGetErrorString_fn)(err, &err_string);
       ^~~~~~~~~~~~~~~~~
       cuGetErrorString
./libavutil/cuda_check.h:39:26: error: expected expression before ‘)’ token
     ((tcuGetErrorString *)cuGetErrorString_fn)(err, &err_string);
                          ^
make: *** [ffbuild/common.mak:60: libavfilter/vf_scale_cuda.o] Error 1
  • A git bisect shows that this is caused by commit 15c6390.
  • Possibly related ticket: #7735.

How to reproduce:

$ git clone https://git.ffmpeg.org/ffmpeg.git
$ cd ffmpeg
$ ./configure --prefix='/usr' --extra-cflags='-I/opt/cuda/include' --extra-ldflags='-L/opt/cuda/lib64' --enable-nonfree --enable-cuda-sdk
$ make -j1

System Information:

  • OS: Arch Linux x86_64
  • ffmpeg: git master
  • Compiler: gcc 8.2.1
  • CUDA: 10.0.130

Change History (2)

comment:1 Changed 3 months ago by cehoyos

  • Component changed from avfilter to undetermined
  • Keywords cuda removed
  • Resolution set to duplicate
  • Status changed from new to closed

See #7742.

comment:2 Changed 3 months ago by bermond

Thanks.

Note: See TracTickets for help on using tickets.