Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#7735 closed defect (fixed)

[git master] Build error: libavutil/cuda_check.c: No such file or directory

Reported by: bermond Owned by:
Priority: important Component: avfilter
Version: git-master Keywords: cuda regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

I'm getting the following error when trying to build ffmpeg git master:

CC      libavfilter/cuda_check.o
libavfilter/cuda_check.c:1:10: fatal error: libavutil/cuda_check.c: No such file or directory
 #include "libavutil/cuda_check.c"
          ^~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make: *** [ffbuild/common.mak:60: libavfilter/cuda_check.o] Error 1

This seems to be caused by the recent commit 15c6390.

How to reproduce:

$ git clone https://git.ffmpeg.org/ffmpeg.git
$ cd ffmpeg
$ ./configure --prefix='/usr' --extra-cflags='-I/opt/cuda/include' --extra-ldflags='-L/opt/cuda/lib64' --enable-nonfree --enable-cuda-sdk
$ make -j1

System Information:

  • OS: Arch Linux x86_64
  • ffmpeg: git master
  • Compiler: gcc 8.2.1
  • CUDA: 10.0.130

Change History (4)

comment:1 Changed 3 months ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important

comment:2 Changed 3 months ago by oromit

  • Analyzed by developer set
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 9e1e5213933dfed529f0cecac7304236a786177e

Confused how this did not break compilation for me initially. Must have had not a single filter enabled.

comment:3 Changed 3 months ago by cehoyos

  • Keywords cuda added

comment:4 Changed 3 months ago by cehoyos

  • Analyzed by developer unset
Note: See TracTickets for help on using tickets.