Opened 12 days ago

Closed 8 days ago

#7726 closed defect (duplicate)

[FFmpeg-vaapi][mpeg2 encode] Driver does not support some wanted packed headers (wanted 0x3, found 0x10)

Reported by: andreyor Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: vaapi crash abort
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

How to reproduce:

build/lin_x64/bin/ffmpeg -y -hwaccel vaapi -vaapi_device /dev/dri/renderD128 -hwaccel_output_format vaapi -i <1920x1080p_29.97_6mb_h264_cabac.264> -frames 600 -c:v mpeg2_vaapi -b:v 10000k -minrate:v 10000k -maxrate:v 10000k -compression_level 4 -g 24 -bf 2 0004_HD03MP2_1_0.mpeg

ffmpeg version N-93001-g87c165c237

Output:

[mpeg2_vaapi @ 0x562db9724840] Driver does not support some wanted packed headers (wanted 0x3, found 0x10).
Assertion 0 && "Invalid RC mode." failed at libavcodec/vaapi_encode_mpeg2.c:545

Change History (3)

comment:1 Changed 12 days ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords vaapi crash abort added

Is a specific input file needed to reproduce?
Please provide the command line you tested together with the complete, uncut console output to make this a valid ticket.

comment:2 Changed 8 days ago by fulinjie

see the comment in #7650:
https://trac.ffmpeg.org/ticket/7650#comment:7

Only VA_ENC_PACKED_HEADER_RAW_DATA is supported as the packed header
for Mpeg2 profile in iHD driver:

Tried to provide a patch to fix this warning, but will trigger a regression in i965 due to the difference in driver:
https://github.com/intel-media-ci/ffmpeg/pull/17
So the patch is not submitted to community.

And the patch set is provided to support more RC mode by Mark:
https://patchwork.ffmpeg.org/patch/12025/

comment:3 Changed 8 days ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #7650.

Note: See TracTickets for help on using tickets.