Opened 9 months ago

Closed 9 months ago

#7678 closed defect (duplicate)

Assertion frame->buf[0] failed at libavcodec/decode.c

Reported by: maxpl0it Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: webp crash abort
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
A frame threaded decoder did not free the frame on failure, causing an assertion to fail at libavcodec/decode.c:619

How to reproduce:

% ffmpeg -i libavcodec_decode_619.webp out.jpg

ffmpeg N-92964-g9217dedcd9
built on MacOS 10.14.2
built with Apple LLVM version 10.0.0 (clang-1000.11.45.5)

Attachments (2)

libavcodec_decode_619.webp (40.5 KB) - added by maxpl0it 9 months ago.
ffmpeg.log (2.7 KB) - added by maxpl0it 9 months ago.

Download all attachments as: .zip

Change History (3)

Changed 9 months ago by maxpl0it

Changed 9 months ago by maxpl0it

comment:1 Changed 9 months ago by cehoyos

  • Keywords webp crash abort added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of ticket #7612.

Note: See TracTickets for help on using tickets.